Extra text added to copy selection (picking up bullet, # from list)

RESOLVED DUPLICATE of bug 78676

Status

()

RESOLVED DUPLICATE of bug 78676
17 years ago
17 years ago

People

(Reporter: spam2, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
On this page I doubled clicked on "dexterous" on definition 1 to highlight it.
It selected "dexterous." which is fine, I believe windows selects the period
when you double click a word. Ctrl-C'd to copy it. But when I pasted it, "#
dexterous." was in the clipboard. Tried multiple times, same thing every time. I
double clicked on "Adroit" in the same definition, it selected "Adroit; " but
when I pasted it, "   1.  Adroit; " was in the clipboard.
If I highlight "Adroit" by click and dragging the mouse over it, "   1.  Adroit"
is  put in the clipboard. If I highlight "dexterous" by click and dragging the
mouse over it, "dexterous" is  put in the clipboard.
Build ID: 2002061104

Comment 1

17 years ago
This is probably a duplicate of another bug; probably not a bug to be on
mjudge's plate.  Should it be reassigned to the serializer or better yet duped
to bug #?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Extra text added to copy selection → Extra text added to copy selection (picking up bullet, # from list)

Comment 2

17 years ago
This sounds like an artifact of the "if the entire list item is selected, select
the <li> too" behavior of the document encoder.  Maybe Joe can elaborate.  A
workaround is to select all but one character of the list item.

Comment 3

17 years ago
From Bug 78676 (original report):
"If I select and copy text from a <li> and the selection includes the first or 
last character of the text in the <li>, I get a bullet at the beginning of the 
pasted text and a newline at the end."  (Although I don't get the newline unless
it's the last li in a list.)  Other comments in the bug discuss which character
is prepended on to the selection in various circumstances.
Bug or feature, either way, this report seems to be talking about the same thing
as Bug 78676, no?

Comment 4

17 years ago
thanks for finding the duplicate!

*** This bug has been marked as a duplicate of 78676 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.