Incorrect url passed to firefox when running second scheme (https), at least on Android

RESOLVED FIXED in Firefox 66

Status

defect
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

(Blocks 1 bug)

Version 3
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

5 months ago
As seen recently in bug 1392946: In a mochitest run on a manifest containing both http and https entries, the url used to launch Firefox for Android for the second (https) iteration has some data duplicated.
Assignee

Comment 1

5 months ago
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=219480862&repo=mozilla-central&lineNumber=3563

10:37:00     INFO -  adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_UPLOAD_DIR=/sdcard/tests/mozlog --es env8 R_LOG_DESTINATION=stderr --es args "-no-remote -profile /sdcard/tests/profile//" --es env3 DISABLE_UNSAFE_CPOW_WARNINGS=1 --es env2 R_LOG_VERBOSE=1 --es env1 XPCOM_DEBUG_BREAK=stack --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_LOG_FILE=/sdcard/tests/mozlog/moz.log --es env6 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env5 MOZ_IN_AUTOMATION=1 --es env4 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env12 MOZ_HIDE_RESULTS_TABLE=1 --es env11 R_LOG_LEVEL=6 --es env10 MOZ_CRASHREPORTER_NO_REPORT=1 -d "https://example.com:443/tests?autorun=1&closeWhenDone=1&logFile=%2Fsdcard%2Ftests%2Flogs%2Fmochitest.log&fileLevel=INFO&consoleLevel=INFO&hideResultsTable=1&manifestFile=tests.json&dumpOutputDirectory=%2Fsdcard%2Ftests&autorun=1&closeWhenDone=1&logFile=%2Fsdcard%2Ftests%2Flogs%2Fmochitest.log&fileLevel=INFO&consoleLevel=INFO&hideResultsTable=1&manifestFile=tests.json&dumpOutputDirectory=%2Fsdcard%2Ftests"

Note "&fileLevel=INFO" appears twice, for instance.
Assignee

Comment 3

5 months ago
With this change we start to actually run android https tests, and some (all?) of them fail. Skip the failing tests for a green run:

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=86f583709bf374ffc16a81010b4325b8a0617978
Assignee

Comment 4

5 months ago
I came across this same issue with self.urlOpts in test-verify. By clearing urlOpts in buildURLOptions(), I can remove my test-verify workaround.
Attachment #9033951 - Flags: review?(bob)
Assignee

Comment 5

5 months ago
I'm still not sure if android https just doesn't work, or if there are just some failing tests. Regardless, we need to skip these to keep the suites green, and, afaik, none of these tests has actually ever run on Android!
Attachment #9033952 - Flags: review?(bob)

Comment 6

5 months ago
Comment on attachment 9033952 [details] [diff] [review]
skip failing android https tests

Review of attachment 9033952 [details] [diff] [review]:
-----------------------------------------------------------------

r+ lgtm.
Attachment #9033952 - Flags: review?(bob) → review+

Comment 7

5 months ago
Comment on attachment 9033951 [details] [diff] [review]
build self.urlOpts from a clean start

Review of attachment 9033951 [details] [diff] [review]:
-----------------------------------------------------------------

r+
Attachment #9033951 - Flags: review?(bob) → review+

Comment 8

5 months ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6c851da6160c
Ensure correct url on multi-scheme mochitest runs; r=bc
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad2ad91d3f99
Skip some https tests on Android; r=bc
Assignee

Updated

5 months ago
Duplicate of this bug: 1461442
Assignee

Comment 10

5 months ago
(In reply to Geoff Brown [:gbrown] from comment #5)
> I'm still not sure if android https just doesn't work, or if there are just
> some failing tests.

Some https tests are running okay on android:

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=219615179&repo=mozilla-inbound&lineNumber=1725-1741

[task 2019-01-02T17:29:28.875Z] 17:29:28     INFO -  runtests.py | Running with scheme: https
[task 2019-01-02T17:29:28.875Z] 17:29:28     INFO -  runtests.py | Running with e10s: False
[task 2019-01-02T17:29:28.875Z] 17:29:28     INFO -  runtests.py | Running with serviceworker_e10s: False
[task 2019-01-02T17:29:28.875Z] 17:29:28     INFO -  runtests.py | Running tests: start.
[task 2019-01-02T17:29:29.186Z] 17:29:29     INFO -  remoteautomation.py | runApp deleted /sdcard/tests/logs/mochitest.log
[task 2019-01-02T17:29:29.496Z] 17:29:29     INFO -  adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_UPLOAD_DIR=/sdcard/tests/mozlog --es env8 R_LOG_DESTINATION=stderr --es args "-no-remote -profile /sdcard/tests/profile//" --es env3 DISABLE_UNSAFE_CPOW_WARNINGS=1 --es env2 R_LOG_VERBOSE=1 --es env1 XPCOM_DEBUG_BREAK=stack --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_LOG_FILE=/sdcard/tests/mozlog/moz.log --es env6 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env5 MOZ_IN_AUTOMATION=1 --es env4 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env12 MOZ_HIDE_RESULTS_TABLE=1 --es env11 R_LOG_LEVEL=6 --es env10 MOZ_CRASHREPORTER_NO_REPORT=1 -d "https://example.com:443/tests?autorun=1&closeWhenDone=1&logFile=%2Fsdcard%2Ftests%2Flogs%2Fmochitest.log&fileLevel=INFO&consoleLevel=INFO&hideResultsTable=1&manifestFile=tests.json&dumpOutputDirectory=%2Fsdcard%2Ftests"
[task 2019-01-02T17:29:40.326Z] 17:29:40     INFO -  remoteautomation.py | Application pid: 1265
[task 2019-01-02T17:30:36.812Z] 17:30:36     INFO -  182 INFO SimpleTest START
[task 2019-01-02T17:30:36.812Z] 17:30:36     INFO -  183 INFO TEST-START | dom/indexedDB/test/test_storage_manager_estimate.html
[task 2019-01-02T17:30:47.032Z] 17:30:47     INFO -  184 INFO TEST-OK | dom/indexedDB/test/test_storage_manager_estimate.html | took 10383ms
[task 2019-01-02T17:30:47.033Z] 17:30:47     INFO -  185 INFO TEST-START | Shutdown
[task 2019-01-02T17:30:47.033Z] 17:30:47     INFO -  186 INFO Passed:  11
[task 2019-01-02T17:30:47.034Z] 17:30:47     INFO -  187 INFO Failed:  0
[task 2019-01-02T17:30:47.034Z] 17:30:47     INFO -  188 INFO Todo:    0
[task 2019-01-02T17:30:47.034Z] 17:30:47     INFO -  189 INFO Mode:    non-e10s
[task 2019-01-02T17:30:47.034Z] 17:30:47     INFO -  190 INFO Slowest: 10382ms - /tests/dom/indexedDB/test/test_storage_manager_estimate.html
[task 2019-01-02T17:30:47.034Z] 17:30:47     INFO -  191 INFO SimpleTest FINISHED

Comment 11

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6c851da6160c
https://hg.mozilla.org/mozilla-central/rev/ad2ad91d3f99
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.