Convert resetProfile.dtd to Fluent

RESOLVED FIXED in Firefox 67

Status

()

P3
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: jaws, Assigned: chenbri2, Mentored)

Tracking

(Blocks: 1 bug)

64 Branch
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

resetProfile.dtd is referenced by safeMode.xul, aboutSupport.xhtml, resetProfile.xul, and resetProfileProgress.xul.

Converting resetProfile.dtd to Fluent will allow aboutSupport.xhtml to remove the dependency on brand.dtd as well, as resetProfile.dtd is the only part of aboutSupport.xhtml that depends on brand.dtd.
Priority: -- → P3

Comment 1

2 months ago

The safe mode case might actually make this tricky - we should make sure to check it. I expect we'll need to move this block of code:

https://searchfox.org/mozilla-central/rev/b4ebbe90ae4d0468fe6232bb4ce90699738c8125/browser/components/nsBrowserGlue.js#1084-1090

to before we show the dialog (a few lines earlier in that function).

Assignee: nobody → chenbri2
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 months ago

Convert resetProfile.dtd to resetProfile.ftl. Modify dependencies for resetProfile.xul, safeMode.xul, aboutSupport.xhtml, resetProfileProgress.xul.
Currently resetProfile.xul does not properly display reset-profile-button. Migration script needs to be edited.

Comment 3

2 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68f9119eacf5
Convert resetProfile.dtd to Fluent r=jaws,flod

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
status-firefox67: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Updated

2 months ago
Duplicate of this bug: 1525110
You need to log in before you can comment on or make changes to this bug.