Closed Bug 1517446 Opened 3 years ago Closed 2 years ago

Firefox does not print complete web pages, including FF's own "See what's new in Firefox" info page

Categories

(Core :: Printing: Output, defect, P3)

63 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- fix-optional

People

(Reporter: youngjane1118, Unassigned)

References

(Regression, )

Details

(Keywords: regression, Whiteboard: [layout:print-triage:p1])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

FF has been incapable of printing out the complete content of most webpages for a very long time. I reported this issue in October and November 2017, but things have only gotten worse as more and more webpages will not print out or save completely as a pdf using FF.  Giant sections of text and numerous pages of content are missing when printing webpages in FF, so I routinely have to copy and paste web addresses into my Safari browser which always creates a complete pdf.

The last straw was when I went to print out and save a pdf of your new FF 64.0 update "See what's new in FF" informational page before downloading it, only to get an incomplete printout using FF.  The entire "Changed" section was missing (see first pdf), so once again I had to copy the web address into Safari, where it created a complete pdf containing all the content on the webpage (see second pdf).  Folks, if you can't even get your own FF informational page to print out completely, then it is no wonder FF is incapable of printing the complete content of most other webpages.


Actual results:

The entire section called "Changed" is missing when printing your webpage or saving it as a pdf, so the entire purpose of saving your FF information page to be able to refer to it down the road was pointless, because FF is incapable of printing a pdf that contains all the content on the page, including your own Firefox information page!  I had to copy the web address into my Safari browser where I was able to print a pdf containing all the content on the page.  I'm glad I can do that, but it's super irritating (and embarrassing for FF) that I have to rely on my Safari browser to print out your own FF informational page.




Expected results:

Firefox should have printed the entire webpage, not just portions of it.  The entire content of a webpage should always be on a printout or pdf, but FF routinely eliminates whole sections of text, if not countless pages. I have created a 12-page pdf using Safari, where Firefox only gives me a 1-page pdf of some obscure section of the webpage; and not necessarily the first page.
I appreciate that you allow users to submit bugs, but this has been an issue that is pervasive across most webpages, and it's not getting addressed.  It's pointless to use Firefox anymore when it is incapable of doing something as elementary as printing a complete copy of a webpage, or saving it as a pdf.

Creating complete pdfs never used to be a issue for FF, but once it started eliminating large sections of text from webpages in October 2017, it has been relentless and increasing.  If I want to print out my shopping cart with a website before placing an order, 9 out of 10 times I am forced to launch Safari so I can create a complete pdf that contains all the pages of my cart, because Firefox will only give me 1 or 2 pages in a totally random fashion.

I realize that each webpage can pose unique challenges for different browsers to reproduce the content properly, but how come Safari never has this trouble?  And if Safari can do it, why has this issue been plaguing Firefox for so long and remaining unresolved?  Thank you.
Interesting, I can reproduce the issue too with nightly
Severity: normal → major
Component: Untriaged → Printing: Output
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Sean, Maire, I know there are a lot of other priority items, but needinfo'ing you so that you're at least aware of the sentiments expressed above.
Flags: needinfo?(svoisen)
Flags: needinfo?(mreavy)
Looks like the printing of a page like this hasn't really worked fully for a long time, with a couple of different problems.
It seems to be something to do with the sticky/fixed/floating "Desktop Android iOS Other Releases" menu/header.

After bisection I got this (it's a shame we don't get narrower bisections any more):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e41d07a703f19224f60b01577b2cbb5708046c9&tochange=67cd1ee26f2661fa5efe3d952485ab3c89af4271

Before these changes, if your scroll position was at the top of the page, it seemed to print fine.
If you scroll down enough to cause the header to float then it gets put at the top of each page obscuring what would normally be there.

Going further back it seems to always print on every page, sometimes messing up the formatting as well as obscuring.

Even further back it seems to flip back to the the almost working case (or working if you print without scrolling down).

Bug 1308876 looks like a possible cause, given the other bugs that it now depends on.
Flags: needinfo?(dbaron)
Ouch!  To the reporter: My sincere apologies for the pain this one has caused. Thanks for taking the time to file a bug.

Thanks, Jonathan, for flagging this to me and to Sean -- and thanks, Bob, for the quick analysis.  

Sean is back from parental leave today, and he & I will make sure this is at the top of Layout's list of bugs that we need to prioritize.

Jonathan (:jwatt) -- How common is this problem across the web?
Flags: needinfo?(mreavy) → needinfo?(jwatt)

To Bob Owen: Thank you for describing another long-standing FF pain in the butt issue that has been bugging me on many PDFs and/or printouts. On the majority of webpages, especially online shopping carts, if I happen to scroll down to view the entire contents of the page and leave the scroll button where it was near the bottom, whatever floating window is at the top of the webpage mysteriously ends up up getting plastered on every single page of the printout obscuring some portion of the text. Eventually I was able to train myself to scroll back up to the top of every webpage before attempting to print it or save it as a PDF. In doing so the floating window stayed put on page 1 where it should be, without it copying itself repeatedly on every subsequent page.

To Marie Reavy: Thank you for the apology and validation of the issue. I'm glad that you appreciate the time that it took to file a bug. When I reported this issue a year ago, it seemed that you needed a report specific to every webpage that Firefox was having trouble with, and I simply was not able to do that due to the volume of websites that Firefox was incapable of printing the complete content for.

a) I filed Bug 1421462 on 10-27-18 pertaining to Credit Karma's website. (It is shown as filed on 1-18-18 on my profile.)

b) I provided other examples on 11-28-17 under Bug 1412697 pertaining to Xfinity's website. (It is shown as filed on 1-18-18 on my profile.)

c) It appears the two bugs are merged as far as the support comments go on Bug 1421462. One of the comments indicated, "We don't print content from a specific technology called Web Components Shadow DOM."

I don't know if that means anything to you, but someone should take a look at those two bugs just in case they have anything useful. It is a year later and the problems still persist. I never heard back from anyone after the initial support responses I received which was disappointing. Hopefully this time around it will be different. Thank you all for your help.

I tried to bisect this further locally, but it's too old to build on my current set-up.
Fortunately, bug 1308876 wasn't too painful to back-out separately.

It looks like it is this changeset where the regression (at least for printing the "What's new" page) occurs:
https://hg.mozilla.org/mozilla-central/rev/1e3130e96f03

Thanks for the taking the time to bisect, bobowen.

Getting this officially on our backlog so we can prioritize fixing our various printing bugs, hopefully in the next few months.

Flags: needinfo?(svoisen)
Priority: -- → P3
Blocks: 1308876
Keywords: regression

For reference, the "See what's new" page (the main testcase here) is at https://www.mozilla.org/en-US/firefox/64.0/releasenotes/

My understanding is we're not going to have another 64 dot release given the impending 65 release.

Much as I'd like to see this (and the other various regressions from bug 1308876) fixed ASAP, it seems unlikely to make it in time for Fx65 with the RC coming next week.

Happy to take a patch in nightly 67, or potentially, in beta 66 for this.
I'm marking it fix-optional to remove it from weekly regression triage, since it has a priority assigned.

Regressed by: 1308876
No longer regressed by: 1308876
No longer blocks: 1308876
Regressed by: 1308876

I'm no longer able to reproduce this in Nightly, but it's possible the site design has changed since this was reported. The navigation for release notes is no longer sticky.

We are doing a sweep of all print output bugs, so will keep this on the radar for now.

Whiteboard: [layout:print-triage:p1]

We've fixed a number of related bugs recently -- but this one seems no longer actionable, since the page in question prints fine, including in older builds from around the time this bug was filed. If you're aware of other pages that don't print correctly, those could use other bugs.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dbaron)
Resolution: --- → WORKSFORME

You are correct, thank you. Since I reported this issue the Firefox Update information pages have been fixed, however, I reported the same exact issue on 7-27-19 with your Firefox Monitor information page which is afflicted by the same issue that the FF update pages had before you fixed the problem. Firefox prints only 1 page (the first page) of the Firefox Monitor information page, while Safari prints out all 15 pages.

I mean this as respectfully as possible because I really like FF as my browser, but I could make a career out of reporting this same glitch with respect to countless webpages when using FF as my browser. The results are always the same. FF gives the user a 1-page incomplete pdf, while Safari provides a complete pdf with ALL the pages.

This issue has been going on for more than 2 years, and I am finding that more and more webpages cannot be successfully printed with Firefox over time. As a result, I have to open Safari to create a pdf or printout. I don't know if FF made a significant change a few years ago that has caused this issue, or if it is other websites that have changed their platforms, but I NEVER used to have this problem with Firefox. Now it is the status quo.

I constantly have to open Safari to do what FF is incapable of doing, and the back and forth exercise is becoming a grand waste of my valuable and limited time. Regrettably, it is getting to the point where if I constantly have to open Safari to print webpages, I might as well work with Safari from the start and forget FF. Thank you.

Assuming by the monitor information page you mean https://monitor.firefox.com/ , then that's an occurrence of bug 939897, and it's not a Firefox regression, but rather more websites using a new layout feature that's never printed correctly in Firefox.

Flags: needinfo?(jwatt)
You need to log in before you can comment on or make changes to this bug.