Firefox Nightly gets an infinite spinner when checking for updates

RESOLVED WORKSFORME

Status

()

defect
P1
blocker
RESOLVED WORKSFORME
4 months ago
3 months ago

People

(Reporter: pascalc, Unassigned)

Tracking

({regression})

Trunk
Desktop
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 affected)

Details

(Reporter)

Description

4 months ago
Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0 ID:20190103220533

Checking manually for an update results in  getting an update window with 'Checking for updates…" message and a spinner that never stops.

The browser console has these errors:

TypeError: this._patches[i] is undefined nsUpdateService.js:1519:7

NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "this._patches[i] is undefined" {file: "jar:file:///home/pascalc/applis/nightly/en-US/omni.ja!/components/nsUpdateService.js" line: 1519}]'[JavaScript Error: "this._patches[i] is undefined" {file: "jar:file:///home/pascalc/applis/nightly/en-US/omni.ja!/components/nsUpdateService.js" line: 1519}]' when calling method: [nsIUpdate::selectedPatch] 

This bug affects all desktop platforms. I don't think this is release automation bug as I don't have the bug with Firefox Beta.
Maybe bug 1517150? It just touched that file
I asked sheriffs to disable updates, to backout 1517150, and to respin
Blocks: 1517150
Quite certain that bug 1517150 caused this though I'm unsure how.
(Reporter)

Comment 4

4 months ago
Simon, could you disable Nightly updates please? Thanks
Flags: needinfo?(sfraser)
Done, please n-i or ping me on irc when you need them re-enabling.
Flags: needinfo?(sfraser)
Is bug also responsible for missing BM-R files on Nightly ?
Severity: critical → blocker
Filed bug 1517743 with a proposed solution for recovering clients that have the code that caused this.
Depends on: 1517743

Updated

4 months ago
Duplicate of this bug: 1517858

Comment 9

4 months ago
I am told that the bug I entered is the same as this


Comment # 1 on Bug 1517858 from Alice0775 White at 2019-01-04 14:54:57 PST

*** This bug has been marked as a duplicate of bug 1517718 ***

I do not get any error messages but it will not download and I am still getting the download to update message

the following is what I reported

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

got message to download update clicked on download nothing appeared to happen
tried to manually download update got update to 66.0a1 (2019-01-04) clicked on window it flashed but nothing happened tried several times same result
running 66.0a1 (2019-01-03)
machine toshiba L850D 
windows 10 1709


Actual results:

nothing


Expected results:

should have downloaded and installed update
Duplicate of this bug: 1517915
That's because the offending patch was backed out and Nightly updates were re-enabled, but your specific build remains stuck. Bug 1517743 will allow these builds to download an update and get back to normal.

In the meantime, you can reinstall Nightly to work around the issue, instead of waiting for bug 1517743.
Duplicate of this bug: 1518020
Duplicate of this bug: 1518037

Updated

4 months ago
Duplicate of this bug: 1518183

Updated

4 months ago
Duplicate of this bug: 1518188

Resolving as wfm with the landing of bug 1517743.

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME

I am still having issues when trying to update. It opens an infinite number of updates that cannot be closed. The only way to stop this is to restart the computer.

Gabriela, please file a bug for this or if you have already filed one add a comment in this bug with the bug number.

Flags: needinfo?(gmontagu)

(In reply to Robert Strong (Robert he/him) [:rstrong] (use needinfo to contact me) from comment #22)

Gabriela, please file a bug for this or if you have already filed one add a comment in this bug with the bug number.

Robert, I´m so sorry but I forgot to comment I face this bug only in my work's Window 7 32 bit PC. I tried to start in Safe Mode and/or disable all addons to check if it was an extension making trouble but I couldn't.
Considering the above, please tell me if it's worthwhile to file a new bug.

Flags: needinfo?(gmontagu)

Comment 24

3 months ago

Hi
As suggested by one of Mozzila's Team some weeks ago I installed the latest version of nightly without uninstalling the version causing the problem
Everything works fine after that
Updates without any problems

You need to log in before you can comment on or make changes to this bug.