Closed Bug 1517726 Opened 9 months ago Closed 8 months ago

promptToChangePasswordWithUsernames references invalid "selectedLogin.userNameField" (incorrect case)

Categories

(Toolkit :: Password Manager, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- fixed

People

(Reporter: standard8, Assigned: plawless, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, regression, Whiteboard: [lang=js])

Attachments

(1 file)

This was introduced by bug 1243729:

newLoginWithUsername.init(aNewLogin.hostname,
                          aNewLogin.formSubmitURL, aNewLogin.httpRealm,
                          selectedLogin.username, aNewLogin.password,
                          selectedLogin.userNameField, aNewLogin.passwordField);

`selectedLogin.userNameField` should be `selectedLogin.usernameField`, as the former isn't defined anywhere:

https://searchfox.org/mozilla-central/search?q=userNameField&case=true&regexp=false&path=

Not sure if this would have any user-facing effects.
Flags: needinfo?(timdream)
(In reply to Mark Banner (:standard8) from comment #0)
> Not sure if this would have any user-facing effects.

It won't because `usernameField` is never used.
Priority: -- → P5
Mentor: timdream
Flags: needinfo?(timdream)
Ah thanks for the clarification.
Whiteboard: [lang=js]
Assignee: nobody → plawless
Status: NEW → ASSIGNED
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/bb5d37aec5da
Corrected case of usernameField. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.