Better link "outgoing server (smtp)" with other mail accounts

RESOLVED DUPLICATE of bug 202468

Status

--
enhancement
RESOLVED DUPLICATE of bug 202468
17 years ago
10 years ago

People

(Reporter: hauser, Assigned: mscott)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The ISP gmx.net asks for a password to be able to send mail to its smtp server.
When I try to send mail - the sending mail progress window loops forever!
From accessing that account via Outlook, I think to recall that there is an
error message coming back from the smtp server mail.gmx.net, but Mozilla's
back-end doesn't catch it.

In the Mail&Newsgroup Account Settings, there is no way to set a outgoing mail
password.

Since I do not trust Mozilla Mail fully yet, I would like to be able to use it
to send mail, but right now, I still want to receive all my mail in MS Outlook.
Therefore, I have not set the account settings to also receive POP3 mail yet.

My Build ID is 2002053012
From the mail window: 
  Edit - Mail & Newsgroup Account Settings
  Select "Outgoing Server (SMTP)"
  Check the box that says "Use Name and Password"

You can also test the POP3 service by checking the 
"Leave messages on server" preference in the "Server
Settings" pane of the account you define.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Sorry, but in my build (downloaded on June 12), there is no 
<<Select "Outgoing Server (SMTP)"
Check the box that says "Use Name and Password">> unfortunately.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

17 years ago
Ralf, are you sure you are looking in the right place. Make sure you open Mail &
Newsgroups, and when you are there go to Edit and then "Mail & Newsgroups
Account Settings". There you will find, to the left, an option called "Outgoing
Server (SMTP)". Take a look at the below screen shot if you still cannot find it.

Comment 4

17 years ago
Created attachment 87671 [details]
Screenshot to help Ralf find this setting.
(Reporter)

Comment 5

17 years ago
André's image solved it for me - the problem was that since I have several news
accounts as well, the "Outgoing Server (SMTP)" was scrolled off the visible part
of the window. To avoid similar problems in the future I have two (or 3)
suggestions:

1) In the mail account settings, the "Advanced button" that shows the little
pop-up window with SMTP server used and lets me switch it if I have defined
multiple servers, have not only a "OK" and "Cancel" button, but also a
"Advanced" or "Edit" or "Configure" that jumps to the "Outgoing Server (SMTP)"
account.

2) When the smtp server refuses to take a mail due to wrong passwords, not just
loop forever, but do something more intelligent (e.g. Outlook comes back and
lets me re-enter a different userid/password) - show at least excerpts of the
received error messages, etc. A time-out would also be good since otherwise a
misconfiguration risks to shut me out of my account due to too many tries with a
wrong userID/password and this creates big hassle to reactivate and thus big
user-frustration.

3) Make sure that the "Outgoing Server (SMTP)" entry somehow is grouped with the
other mail accounts. (for me, it comes after the many "n"s in the name of the
various newsfeeds

Thanks for the quick help anyway!
Thanks for the help André.
Ralf thanks for the suggestions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Quinn,

You put the status to "Resolved".
Is there an infrastructure similar to bugzilla where I can see how my
suggestions make it in the further development of the software? Can I formally
enter them somewhere?
Otherwise, I suggest to keep the bug open as I did with a new title and
enhancement severity.

Rgds Ralf 
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: where to enter password for outgoing smtp mail → Better link "outgoing server (smtp)" with other mail accounts

Comment 8

17 years ago
change qa contact ->nbaca.
Ninoschka, 
Please reassign the bugs if not in your area.
QA Contact: sheelar → nbaca
I think it is a valid request to have a direct access from the advanced panel to
the configuration of the SMTP setup.

changeing component
Status: UNCONFIRMED → NEW
Component: Networking: SMTP → Account Manager
Ever confirmed: true

Comment 10

16 years ago
Outgoing Server (SMTP) should be a property of the account, not a
global/stanalone setting that's tied to the account somehow. Currently, there
appear to be no way to use several email accounts that have different outgoing
servers (Mozilla keeps asking for password and tries to connect to the wrong
server). 

One possible way to fix this is:
1) In the "Server Settings" window change "Server Name" to "Incoming Server Name"
2) Add new field "Outgoing Server Name" (and port/id, if necessary)
3) Remove global "Outgoing Server (SMTP)" window completely

Thanks!

Comment 11

15 years ago
For the last comment:
You are absolutely right, I cannot really understand why it wasn't done right in
the first place. By hacking 'round about:config or the prefs.js file it can be
solved too as seen in http://bugzilla.mozilla.org/show_bug.cgi?id=119609 but it
does not make sense the way it is now (one more vote to give)

Comment 12

15 years ago
I'm also very much in need of having the outgoing server setting as part of the
account definition.  The distinction between private and coorporate addresses is
necessary.  Corporate mail might need to go through the company mail servers
while personal mail directly goes out to the internet.  This is nothing sendmail
et.al. can do, this is a property of the account.
Product: Browser → Seamonkey
Big SMTP related UI improvement is in progress under Bug 202468.
So closing as DUP of Bug 202468.
Comment to Bug 202468, please.
And if you will not be satisfied with solution by Bug 202468, request another
enhancement.


*** This bug has been marked as a duplicate of 202468 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.