Firefox 65 websocket via proxy not working

RESOLVED DUPLICATE of bug 1514688

Status

()

defect
RESOLVED DUPLICATE of bug 1514688
5 months ago
5 months ago

People

(Reporter: waclaw66, Unassigned)

Tracking

({regression})

65 Branch
Points:
---

Firefox Tracking Flags

(firefox64 unaffected, firefox65 affected)

Details

Attachments

(1 attachment)

116.15 KB, application/x-zip-compressed
Details
Reporter

Description

5 months ago
Posted file logs.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

1. Install fresh Firefox 65 onwards (tested 65b3, 65b7, 66a1).
2. Setup some forwarding proxy server (tested Apache/2.4.37, tinyproxy 1.10.0) within Firefox with using for all protocols.
3. Go to address https://doozer.io/tvheadend/tvheadend

Tested on Firefox 64, Chrome, Edge without any trouble.


Actual results:

Websocket cannot be estabilished. No branches shown on the doozer website.


Expected results:

Websocket should be estabilished and some branches loaded and shown.
Could be related to bug 1514688

Reporter: 
Could you run our mozregression tool to find the change that caused this ?
- https://mozilla.github.io/mozregression/

I would do it but I'm currently not at home and do not have a proxy server available.
Component: Untriaged → Networking: WebSockets
Flags: needinfo?(waclaw66)
Keywords: regression
Product: Firefox → Core
Flags: needinfo?(bugzilla)
Reporter

Comment 2

5 months ago
Regression tests (by the way very nice tool ;)) found this commit...

Bug 1434137 - Implement websockets over http/2 - RFC 8441 r=michal,dragana

https://tools.ietf.org/html/rfc8441

This uses our existing http/2 CONNECT infrastructure (modified) to
enable the new extended CONNECT form defined by 8441, and pretend for
the websocket's sake that an http/2 stream is actually a socket. From
the websocket's point of view, this is relatively non-invasive - a few
things have changed (http response code, absence of some headers) versus
http/1.1 websockets, but for the most part, the websocket code doesn't
care.

Differential Revision: https://phabricator.services.mozilla.com/D8016
Flags: needinfo?(waclaw66)
Thank you very much for doing the work !
This could be indeed a dupe of bug 1514688 which will be hopefully fixed in the Firefox65 final version.
Flags: needinfo?(bugzilla) → needinfo?(dd.mozilla)
See Also: → 1514688
Reporter

Comment 4

5 months ago

I can confirm that the fix of Bug 1514688 (FF66a1 build ID 20190108101613) has also fixed this issue.

Thank you very much that you tested the fixed build !

Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(dd.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1514688
You need to log in before you can comment on or make changes to this bug.