Closed Bug 1517849 Opened 2 years ago Closed 2 years ago

Integrate telemetry for Top Stories into the new GCP data pipeline

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 67
Iteration:
67.3 - Feb 25 - Mar 10
Tracking Status
firefox67 --- fixed

People

(Reporter: nanj, Assigned: nanj)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file)

We're looking to integrate the telemetry for Top Stories into the new data pipeline. The server side change is ready and deployed in production, we'd like to test it by having users in the prerelease channel to send telemetry to the new pipeline.

Note:

1. The same telemetry will also be sent to the old pipeline until we finish the verification
2. The server side work is tracked at https://github.com/mozilla-services/mozilla-pipeline-schemas/pull/228
Blocks: 1517848
Iteration: --- → 67.1 - Jan 28 - Feb 10
Priority: -- → P2
Iteration: 67.1 - Jan 28 - Feb 10 → 67.2 - Feb 11 - 24
Assignee: nobody → najiang
Priority: P2 → P1
Iteration: 67.2 - Feb 11 - 24 → 67.3 - Feb 25 - Mar 10

Confirmed with our data steward :chutten that this patch does NOT need a data review since it hasn't added/changed any telemetry in Activity Stream. Using the new data pipeline on GCP has already been approved separately.

Blocks: 1532321
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.