Closed Bug 1517943 Opened 8 months ago Closed 8 months ago

Middle-Mouseclick on bookmark folder not working any more

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.53 Branch
defect
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 fixed)

RESOLVED FIXED
SeaMonkey2.63
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- fixed

People

(Reporter: jou, Assigned: frg)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53

Steps to reproduce:

Seamonkey 2.53.* (and 2.57 too):
Have a bookmark folder.
Click with middle mouse on that folder.


Actual results:

Nothing.


Expected results:

Open all links in that folder in tabs, the same action as selecting "Open All in tabs" within that folder.
With Seamonkey up to 2.49.x it worked, and I simply miss it since it is so much faster than the extra navigation to the "Open All in tabs". Especially if you have such folders in your bookmark toolbar, single click and done.
Timestamp: 1/6/2019, 12:06:50 AM
Error: TypeError: aView is undefined
Source File: resource:///modules/PlacesUIUtils.jsm
Line: 979

Library port patches in bug 1378089 missed some parts from Bug 562998.
Assignee: nobody → frgrahl
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
The Fx changes to onCommand where reverted in Bug 1354159 - Part 1. This was alrady ported so only onClick needs the new view parameter. It also seems a comment was misplaced in Bug 260611 for Fx and this was copied 1:1 into SeaMonkey. Revert this.
Attachment #9034587 - Flags: review?(iann_bugzilla)
Attachment #9034587 - Flags: approval-comm-esr60?
Comment on attachment 9034587 [details] [diff] [review]
1517943-placesmiddlemouse.patch

r/a=me
Attachment #9034587 - Flags: review?(iann_bugzilla)
Attachment #9034587 - Flags: review+
Attachment #9034587 - Flags: approval-comm-esr60?
Attachment #9034587 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/477951a3314a
Associate bookmarksEventHandler onClick and onCommand with a places view. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Thank you!
You need to log in before you can comment on or make changes to this bug.