Closed Bug 1518069 Opened 11 months ago Closed 10 months ago

graphical cursor affects the z-index on elements with 3d transformation (with preference: accessibility.browsewithcaret=true)

Categories

(Core :: Web Painting, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- verified

People

(Reporter: hunboy, Assigned: miko)

References

Details

(Keywords: regression)

Attachments

(5 files)

Attached file zindexbug.html
Repro: see attchaed testcase, click next to the images on the screen to get graphical cursor on the screen.

AR: the cursor affects the z-index permanently on my platform. so image "blinks" with the cursor. Actually z-index "blinks", ignores z-index;

ER: graphical cursor doesn't affect the z-index.


Note: this is the minimum testcase, if I remove anything, the bug disappears. So summary:

- 3d-transform
- z-index defined

I could not find any workaround to fix this via css.

Some similar bug I found: Bug 1350804
Not same, thats for SVGs.
Additional info: if you double-click on the frame to select (with blue painting) the image, it works ok

I can't reproduce any issues with images "blinking" locally, for what its worth. I tried the attached testcase as well as http://jsfiddle.net/utasir/7zn3feLs (the demo shown in the screencast). I tested using Nightly on Linux, as well as Firefox 64 on Windows 10 via BrowserStack.

I wonder if this might be a graphics driver bug?

Attachment #9034712 - Attachment description: screen.mp4 → screencast of the bug happening in jsfiddle testcase

For reference, here's a screencast of me trying to reproduce with BrowserStack "remote" windows 10 + Firefox 64. In the screencast, you can see my cursor moving around, and I'm intermittently clicking (on & near the image), but I can't reproduce any blinking-away issues.

hunboy, would you mind going to about:support and copypasting the "Graphics" section into a text file & posting that as an attachment here? [EDIT: never mind about this, comment 6 seems to be a better diagnostic]

There's a chance some graphics-knowledgeable folks (not me) might be able to glean some information about possible sources of trouble from that, or at least figure out correlations perhaps.

Flags: needinfo?(utasir)

I can reproduce this if I set accessibility.browsewithcaret=true, but not without (since there's nothing editable, and no caret).

(In reply to Matt Woodrow (:mattwoodrow) from comment #6)

I can reproduce this if I set accessibility.browsewithcaret=true, but not without (since there's nothing editable, and no caret).

I can confirm this idea, when I turn it to false, the bug disappears.

Flags: needinfo?(utasir)
Has Regression Range: --- → yes

Given the regression range (the smaller one in the lower link in comment 9): hunboy suggests (and I agree) that this seems likely to be a regression from bug 1214212:

e19090d182fa Thinker K.F. Li — Bug 1214212 - Remove clips from separator transform items. r=roc
https://hg.mozilla.org/mozilla-central/rev/e19090d182fa

--> marking as such

Blocks: 1214212
Keywords: regression
Summary: graphical cursor affects the z-index on elements with 3d transformation → graphical cursor affects the z-index on elements with 3d transformation (with preference: accessibility.browsewithcaret=true)
OS: Windows 10 → All
Hardware: x86_64 → All
Priority: -- → P3

:miko, can you comment to the bug? Since you worked for css3d, thanks.

Flags: needinfo?(mikokm)

I think this problem is caused by caret item causing the content to be wrapped in nsDisplayWrapList, which causes us to create a transform separator1 for the transformed content.

Assignee: nobody → mikokm
Status: NEW → ASSIGNED
Component: Graphics: Layers → Web Painting
Flags: needinfo?(mikokm)
Pushed by mikokm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ad20edb20e58
Do not use transform separators for nsDisplayWrapList containing just nsDisplayTransform r=mattwoodrow
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Verified - Fixed on latest Nightly 66.0a1 (2019-01-28) (64-bit) on Windows 10, Ubuntu 16.04 and Mac OS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.