Closed Bug 1518144 Opened 4 years ago Closed 2 years ago

aldi.co.uk supermarket site layout is broken in Firefox (due to script that positions the grid getting blocked)

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: jwatt, Unassigned)

References

Details

(Whiteboard: [tp-needsrepro][tp-shim-trivial][tp-site-ephemeral])

The layout of this page is very visibly broken in Firefox, but works in Chrome:

https://www.aldi.co.uk/c/groceries
This is a content blocking issue. Disabling content blocking makes the script that positions the items load.
Component: Layout → Tracking Protection
Priority: P3 → --
Product: Core → Firefox
Summary: aldi.co.uk supermarket site layout is broken in Firefox → aldi.co.uk supermarket site layout is broken in Firefox (due to script that positions the grid getting blocked)
Blocks: tp-breakage
Whiteboard: [webcompat] → [tp-needsrepro]
Priority: -- → P3
Component: Protections UI → Privacy: Anti-Tracking
Product: Firefox → Core

The page looks fine now, but there is a delay caused by them using the Google Optimizer anti-flicker/asynchide code snippet (which we can work-around with a shim, as mentioned in bug 1628151.

No longer blocks: tp-breakage
Whiteboard: [tp-needsrepro] → [tp-needsrepro][tp-shim-trivial][tp-site-ephemeral]

This is now fixed by SmartBlock as of bug 1687942.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.