Closed Bug 1518270 Opened 3 years ago Closed 3 years ago

shadow dom tab navigation breaks with nested shadow doms

Categories

(Core :: DOM: Core & HTML, defect)

64 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1512043

People

(Reporter: derek.randall.moss, Assigned: edgar)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

demo: https://shadow-dom-tab-order.stackblitz.io
source: https://stackblitz.com/edit/shadow-dom-tab-order

Assumes you are using the demo above.

  1. select "1A" button
  2. press "Tab" key

Actual results:

focuses button "2"

Expected results:

focuses button "1B"

Component: Untriaged → DOM
Product: Firefox → Core

Edgar may know what's up here.

Blocks: shadowdom
Flags: needinfo?(echen)

bug 1512043 should also fix this, and it works well with recent Nightly.

Assignee: nobody → echen
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(echen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1512043

(In reply to Edgar Chen [:edgar] from comment #2)

bug 1512043 should also fix this, and it works well with recent Nightly.

*** This bug has been marked as a duplicate of bug 1512043 ***

Confirmed that it works in 66.0a1

Thank you!

Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.