(picture-caching) Low fps on WebGL jellyfish

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: sotaro, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

When I visited http://arodic.github.io/p/jellyfish/, fps was very low like 10fps on my laptop(P50 Win10).

Without picture caching, fps was 60fps.

Priority: -- → P3

I tested this on my machine, and it's around 10-20% slower with picture caching. This is currently expected since WR is caching tiles that are constantly changing, so it's redundant work. I'm planning to work on a patch today that skips caching if the tiles are constantly changing.

However, it sounds like the slowdown you are seeing is much worse than what I am seeing, which is concerning. Could you provide a screenshot of the WR profiler overlay while running with/without picture caching on this page?

Flags: needinfo?(sotaro.ikeda.g)

Potential fix / workaround is https://github.com/servo/webrender/pull/3487 - although I'd still like to see some WR profile graphs of this case, since the difference is very significant and I can't repro here.

Flags: needinfo?(sotaro.ikeda.g)

(In reply to Glenn Watson [:gw] from comment #1)

However, it sounds like the slowdown you are seeing is much worse than what I am seeing, which is concerning. Could you provide a screenshot of the WR profiler overlay while running with/without picture caching on this page?

I posted the screenshots. Are they what you expected?

Thanks for the screenshots!

Those results are what I hoped to not see, but suspected might be the case. The bright green bars are GPU time to create the cache tiles - on my machines, those are typically 10-20% of the frame time, worst case. On your setup, they are taking a massive amount of time :( I wonder if they are hitting some kind of slow path in ANGLE / D3D on your device. Could you post the output of your about:support so I can try to repro on a similar GPU?

P50 was mozilla's standard windows laptop for development. Then it might exist in Toronto office.

Thanks - I have one here with the same or similar Intel GPU (which is what is active in the about:support). I'll do some profiling to see if that blit path is particularly slow on that GPU, thanks.

Sotaro, is this resolved for you in the current build?

Flags: needinfo?(sotaro.ikeda.g)

On P50, fps was improved from 10fps to 51 fps! It is a bit lower than disabling picture cache, but from Comment 1, it seems to be expected regression.

Flags: needinfo?(sotaro.ikeda.g)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.