Remove the MOZ_TOOLKIT_SEARCH define

RESOLVED FIXED in Firefox 68

Status

()

task
P2
normal
RESOLVED FIXED
5 months ago
28 days ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 68
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

5 months ago

During the review phase of bug 1492475, we noticed that the 'MOZ_TOOLKIT_SEARCH' build-time define doesn't really serve a purpose anymore.
Let's remove it.

Comment 1

4 months ago
Flags: needinfo?(mdeboer)

Updated

4 months ago
Assignee: nobody → 1991manish.kumar

Updated

4 months ago
Duplicate of this bug: 1510994
Assignee

Comment 3

4 months ago

Yes, I think that's correct, Manish. Thanks for taking a look!

Flags: needinfo?(mdeboer)

Hi Manish, did you see Mike's comments on the patch?

Are you still working on this?

Type: enhancement → task
Points: --- → 1
Flags: needinfo?(1991manish.kumar)
Blocks: 1542235

Sorry not able to give time because of my Ph.D.
I am un-assigning this bug.

Flags: needinfo?(1991manish.kumar)

Updated

a month ago
Assignee: 1991manish.kumar → nobody
Assignee

Updated

a month ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: P3 → P2

Comment 9

29 days ago
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da2bd2908b71
Remove the 'MOZ_TOOLKIT_SEARCH' build config constant, because it's unused; we always enable the search service. r=florian
Status: ASSIGNED → RESOLVED
Last Resolved: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.