Closed Bug 1518715 Opened 3 years ago Closed 3 years ago

Baseline alignment of an inline-flex item breaks when overflow is specified (due to the anonymous box it creates?)

Categories

(Core :: Layout: Flexbox, defect)

66 Branch
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 969874

People

(Reporter: cybai, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

While reading tweets on twitter, I found the "X" number of "X Likes" is not in the same line with "Likes".

For example, checking this tweet: https://twitter.com/intenttoship/status/1076808631125983232

The reduced test case is in the attatchment or here's a codepen for it: https://codepen.io/anon/pen/PXBjvK.

Actual results:

The number of likes is not in the same line with Likes.

Expected results:

The number should be in the same line with Likes.

Baseline alignment breaking when overflow is present looks something suspicious to me. Daniel, I recall some flexbox bug related to the scrollframe anon box as well, do you know if this is related?

Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Flexbox
Ever confirmed: true
Flags: needinfo?(dholbert)
Product: Firefox → Core
Summary: overflow-y works incorrectly with inline-flex → Baseline alignment of an inline-flex item breaks when overflow is specified (due to the anonymous box it creates?)

This is likely bug 969874 (which got some spec text to clarify the expected result [and to clarify that "display:inline-block" is a special case that we shouldn't match here] in https://github.com/w3c/csswg-drafts/issues/2902 )

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 969874

I can reproduce the bug at Twitter, too, but only if I go to mobile.twitter.com to force "new" twitter.

So, here's a more-reliably-reproducing URL:
https://mobile.twitter.com/intenttoship/status/1076808631125983232

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.