Closed Bug 1518805 Opened 11 months ago Closed 11 months ago

Crash in mozilla::a11y::Accessible::Bounds

Categories

(Core :: Disability Access APIs, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: calixte, Assigned: eeejay)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-ff0da861-94b7-47ed-a7d8-7bc310190109.

Top 10 frames of crashing thread:

0 libxul.so mozilla::a11y::Accessible::Bounds const accessible/generic/DocAccessible.h:135
1 libxul.so mozilla::a11y::AccessibleWrap::ToSmallBundle accessible/android/AccessibleWrap.cpp:591
2 libxul.so mozilla::a11y::SessionAccessibility::UpdateCachedBounds accessible/android/SessionAccessibility.cpp:386
3 libxul.so mozilla::a11y::DocAccessibleWrap::UpdateFocusPathBounds accessible/android/DocAccessibleWrap.cpp:258
4 libxul.so mozilla::a11y::DocAccessibleWrap::HandleAccEvent accessible/android/DocAccessibleWrap.cpp:74
5 libxul.so nsEventShell::FireEvent accessible/base/nsEventShell.cpp:43
6 libxul.so mozilla::a11y::DocAccessible::DispatchScrollingEvent accessible/generic/DocAccessible.cpp:2278
7 libxul.so mozilla::a11y::DocAccessible::ScrollPositionDidChange accessible/generic/DocAccessible.cpp:575
8 libxul.so mozilla::ScrollFrameHelper::ScrollToImpl layout/generic/nsGfxScrollFrame.cpp:2872
9 libxul.so mozilla::ScrollFrameHelper::CompleteAsyncScroll layout/generic/nsGfxScrollFrame.cpp:2089

=============================================================

There are 54 crashes (from 33 installations) in nightly 66 with buildid 20190109092644. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1518253.

[1] https://hg.mozilla.org/mozilla-central/rev?node=01d64b7442cd

Flags: needinfo?(eitan)

The crash signature soccoro link is misleading, only mentions 3 oldish crashes from last year.

Assignee: nobody → eitan
Flags: needinfo?(eitan)
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/460f0359741b
Don't update bounds on gone or defunct accessibles. r=MarcoZ
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1512568
You need to log in before you can comment on or make changes to this bug.