[Content Blocking] Icons from preferences are invisible on high contrast mode

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
7 months ago
4 months ago

People

(Reporter: david.olah, Assigned: ewright)

Tracking

({access})

Trunk
Future
Unspecified
Windows
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox65 wontfix, firefox66 wontfix, firefox67 fixed, firefox68 fixed)

Details

(Whiteboard: [anti-tracking])

Attachments

(3 attachments)

Posted image CB_Standard.png

[Enviroments:]
Windows 10, Windows 7
66.0a1 (2019-01-09)

[Steps:]

  1. Set a high contrast theme (example: black).
  2. Open Firefox.
  3. Open hamburger menu / select content blocking.

[Actual Result:]
The icons are the same color as the background and cannot be seen.

[Expected Result:]
The icons convert color to white as the rest of the icons from Mozilla options pages.

[Note]
In the Attachments you can see a comparison between standard and High contrast mode.

Posted image CB_High_Contrast.png
Priority: -- → P3
Target Milestone: --- → Future
Keywords: access
Component: Tracking Protection → Privacy: Anti-Tracking
Product: Firefox → Core

This isn't a Core bug?

Flags: needinfo?(amarchesini)

Right. Firefox preferences is better.

Component: Privacy: Anti-Tracking → Preferences
Flags: needinfo?(amarchesini)
Product: Core → Firefox
Whiteboard: [anti-tracking]

High contrast mode does not render background images, set as list-style image instead. Fix fill colors for other icons.

Assignee: nobody → ewright
Status: NEW → ASSIGNED
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01a2fee54f94
Icons and images are visible on high contrast mode. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

This small CSS patch looks contained and safe and fixes an obvious visual bug with high-contrast themes, Erica do you want to request an uplift to 67 Beta or do you prefer to let it ride the trains to 68?

Flags: needinfo?(ewright)

Sure, I can request uplift.

Flags: needinfo?(ewright)

Comment on attachment 9051839 [details]
Bug 1518807 - Icons and images are visible on high contrast mode.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1501985
  • User impact if declined: in high contrast mode, icons are not visible in about:preferences#privacy section.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): just css change
  • String changes made/needed: none
Attachment #9051839 - Flags: approval-mozilla-beta?

Comment on attachment 9051839 [details]
Bug 1518807 - Icons and images are visible on high contrast mode.

Safe patch for a visible bug in high contrast mode, uplift approved for 67 beta 7, thanks.

Attachment #9051839 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I verified this issue on latest Nightly 68.0a1 (20190407214820) using Windows 7 x64, but it seems that some icons are still not displayed in about:preferences when High Contrast mode is applied. In "Standard" and "Strict" mode the icons are missing for "Known trackers only in Private Windows" and "Third-party tracking cookies"; please observe the image.

Any thoughts about this, Erica?

Flags: needinfo?(ewright)

(In reply to Ciprian Georgiu [:ciprian_georgiu], Release Desktop QA from comment #12)

I verified this issue on latest Nightly 68.0a1 (20190407214820) using Windows 7 x64, but it seems that some icons are still not displayed in about:preferences when High Contrast mode is applied. In "Standard" and "Strict" mode the icons are missing for "Known trackers only in Private Windows" and "Third-party tracking cookies"; please observe the image.

Any thoughts about this, Erica?

looks like I missed them, Another note, the chevron up and down were also missed.

Flags: needinfo?(ewright)
Blocks: 1542916
Regressions: 1542916
You need to log in before you can comment on or make changes to this bug.