Closed Bug 1518917 Opened 10 months ago Closed 7 months ago

Consider maintaining a clipped area for OOP iframes

Categories

(Core :: Graphics, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1519546
Fission Milestone M3

People

(Reporter: jwatt, Assigned: rhunt)

References

(Blocks 2 open bugs)

Details

There are various places in our code that want to know if something is "hidden" in some sense (scrolled out of view, or clipped, etc.). Accessible::VisibilityState is one example. This code uses GetCrossDocParentFrame to walk the frame tree to the top of the top-level document. For oop-frames, that will no longer be possible.

The APZ machinery can probably help, but it may be necessary to maintain clipping information on oop-frames to continue to facilitate the checks that we do now. That's complicated by animation, transforms, etc. Perhaps at display list construction time in the parent we can send the latest information to embedded oop-frames?

Depends on: 1518919
No longer depends on: 1518919

I talked this over with rhunt and we concluded that a GFX person would be best positioned to work on this. Ryan will investigate and thinks this may be a good Fission M2 candidate.

Assignee: nobody → rhunt
Fission Milestone: --- → ?
Fission Milestone: ? → M2
Status: NEW → ASSIGNED
Component: Layout → Graphics
Flags: needinfo?(rhunt)
No longer blocks: graphics-fission
Fission Milestone: M2 → M3
Summary: Consider maintaining a clipped area for oop-iframes → Consider maintaining a clipped area for OOP iframes

I'm closing this in favor of bug 1519546.

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1519546
You need to log in before you can comment on or make changes to this bug.