Closed Bug 151896 Opened 19 years ago Closed 18 years ago

css font-formating ignored with input type="file"

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Windows 2000
defect

Tracking

()

RESOLVED DUPLICATE of bug 52500
Future

People

(Reporter: bugzilla, Assigned: rods)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020614
BuildID:    2002061408

Changing the fontsize in input type="file" seems not to be possible.

input {font-family:verdana,helvetica,geneva; font-size:10px;}
works with input type="text" (as you can see in the example URL).
type="file ignores the size.

Appears on Win2k
Mozilla 1.0 and 1.1.a 2002061408

Reproducible: Always
Steps to Reproduce:

1. create <style type="text/css">
input {font-family:verdana,helvetica,geneva; font-size:10px;}
</style>
2. <input name="userfile" type="file">
3. same with <input style="font-family:verdana,helvetica,geneva;
font-size:10px;" name="userfile" type="file">

Actual Results:  font-size does affect neither the button nor the text in the
field itself

Expected Results:  fontsize of button and field should be as big as given in
style="font-size"
same behaviour expected as in input type="text"

<html>
<head>
<style type="text/css">
input {font-family:verdana,helvetica,geneva; font-size:10px;}
</style>
</head>
 <body>

<form enctype="multipart/form-data" action="" method="post"> 
<input type="text" value="foo"><br>
<input name="userfile" type="file"><br>
<input style="font-family:verdana,helvetica,geneva; font-size:10px;"
name="userfile" type="file"><br>
</form>

</body>
</html>
I see this behaviour as well.
The fact that is does not work is probably a bug with our implementation. But
the CSS spec doesn't cover the styleing of form controls yet. We should be
competely disallowing any and all styling of forms controls.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Future
Isn't this a dupe of your other assigned bug, bug 52500?

*** This bug has been marked as a duplicate of 52500 ***
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.