Last Comment Bug 151909 - X-remote does not distinguish between profiles
: X-remote does not distinguish between profiles
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: X-remote (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: Christopher Blizzard (:blizzard)
:
Mentors:
Depends on: 237283
Blocks: 122698 151863
  Show dependency treegraph
 
Reported: 2002-06-14 15:00 PDT by Andrew Schultz
Modified: 2004-04-08 07:02 PDT (History)
7 users (show)
blizzard: blocking1.4-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (11.49 KB, patch)
2002-06-15 06:26 PDT, Andrew Schultz
no flags Details | Diff | Splinter Review
patch including gtk2 (14.03 KB, patch)
2002-06-16 22:08 PDT, Andrew Schultz
blizzard: review-
Details | Diff | Splinter Review

Description Andrew Schultz 2002-06-14 15:00:58 PDT
If you use X-remote commands with two or more Mozilla profiles (same user) open
on the same display, X-remote cannot distinguish between them and performs
operations on whichever window was used last.

This would help to ensure a proper implementation of bug 122698 and would also
help resolve problems in bug 151863.
Comment 1 Andrew Schultz 2002-06-15 06:26:23 PDT
Created attachment 87786 [details] [diff] [review]
patch

patch that works.
there might be a better way to do GetCurrentProfile.  I just stole that from
nsAppShellService.cpp
Comment 2 Andrew Schultz 2002-06-16 22:08:58 PDT
Created attachment 87893 [details] [diff] [review]
patch including gtk2

patch includes gtk2.  I haven't tested with gtk2, but the relevant parts of the
code are identical.
Comment 3 Andrew Schultz 2002-09-03 13:17:06 PDT
Blizzard, could you review the patch (or WONTFIX this bug :()

thanks
Comment 4 Thomas F. O'Connell 2003-03-13 07:43:00 PST
This is a pretty frustrating bug for anyone on GNU/Linux using a Mozilla-based
browser to open URLs from other applications. There's a patch posted. Is there
any hope of speeding up the review process?
Comment 5 Andrew Hagen 2003-05-02 12:07:20 PDT
Patch exists.
Comment 6 Christopher Blizzard (:blizzard) 2003-05-02 12:15:03 PDT
Not blocking 1.4.
Comment 7 Vaclav Dvorak 2003-11-19 08:21:08 PST
As Christopher Blizzard seems to be too busy for this, is there anyone else who
could do the review? Thanks. Although this bug in itself is probably not very
visible, it's supposedly blocking bug 122698 which is a PITA for virtually
everyone on Unix.
Comment 8 alanjstr 2003-11-19 08:50:01 PST
Has this patch bitrotted at al?
Comment 9 Christopher Blizzard (:blizzard) 2003-11-20 10:53:34 PST
We're about to make some changes to the xremote code to handle firebird/tbird
changes.
Comment 10 Christopher Blizzard (:blizzard) 2004-04-08 07:02:33 PDT
Patch in bug 237283 fixed this.

Note You need to log in before you can comment on or make changes to this bug.