Closed Bug 1519160 Opened 11 months ago Closed 11 months ago

Middle click on the Tabs Bar does not create a new tab

Categories

(Toolkit :: XUL Widgets, defect, P2)

66 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified
firefox68 --- verified
firefox69 --- verified

People

(Reporter: okazki98, Assigned: timdream)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

  1. Middle click on empty space on the tabs bar.

Actual results:

Clicking with the mouse wheel does not create a new tab. Anywhere else the middle click actions are working as expected (e.g clicking on a link to open in a new tab, closing tabs, opening parent tab clone when middle clicking on the "New tab" button).

Only the 66 branch is affected. Release and Beta are working as expected.

Expected results:

When middle clicking create a new tab.

Blocks: 1454357
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → XUL
Ever confirmed: true
Flags: needinfo?(timdream)
Keywords: regression
Product: Firefox → Core

Thanks for filing. It's pretty sad that there wasn't a test...

Component: XUL → XUL Widgets
Flags: needinfo?(timdream)
Product: Core → Toolkit

The feature broke was bug 573438.

See Also: → 573438
Wich the scrollbox binding gone the tag name to check should be "scrollbox" instead of "box".
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by tchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd2b5b6a3048
Restore middle click & double click on tabstrip to open new tabs r=dao
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Flags: qe-verify+

Confirmed the issue with 66.0a1 (2019-01-10) on Windows 10 x64, Ubuntu 18.04 x64, macOS 10.11.6.
Fix verified with 66.0b3 build1 (20190128143734), Windows 10 x64, Ubuntu 18.04 x64, macOS 10.11.6.
I have a misunderstanding though - the free space that remains before the minimize button when having multiple opened tabs cannot be used for creating a new tab by middle clicking. Is this intended?

Flags: needinfo?(timdream)

I believe so, but the best way to be sure is to open up an unaffected version and compare their behaviors. The fix here is intended to restore the behavior to what the unaffected version does.

If that little space seems confusing and should open a new tab when middle-clicked, that's probably another bug.

Flags: needinfo?(timdream)

The behavior mentioned by Iulia in comment 8 is the same on affected builds and one after the fix. My personal opinion is that it's intended. I will set this bug as verified based on the testing above + testing in latest Nightly (v69.0a1 from 2019-06-06) and the current release (v67.0.1).
Thank you!

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Since it has been verified for nightly and release, is it verified for beta too?
For more information, please visit auto_nag documentation.

Also verified Beta v68.0b8.

You need to log in before you can comment on or make changes to this bug.