Closed Bug 1519317 Opened 11 months ago Closed 11 months ago

Shaka Player demo shows MEDIA.VIDEO_ERROR on loop enabled

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 + verified
firefox66 + verified

People

(Reporter: Anca, Assigned: alwu)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screencast issue.gif

[Affected versions]:

  • 66.0a1 (20190110093854)
  • 65.0b10 (20190110221328)

[Affected platforms]:

  • Windows 10 x64
  • macOS 10.13
  • Ubuntu 16.04 x86

[Steps to reproduce]:

  1. Go to http://goo.gl/0cVfha
  2. Right click on the video and enable the Loop option
  3. Observe the behavior once the demo is finished

[Expected result]:

  • The demo plays again.

[Actual result]:

  • “Shaka Error MEDIA.VIDEO_ERROR (3,,NS_ERROR_DOM_MEDIA_WAITING_FOR_DATA (0x806e0009))” error message is displayed.

[Regression range]:

[Additional Notes]:

  • This issue was encountered as part of Widevine feature testing, affected version 4.10.1146 and 4.10.1196.
  • No other demo has this behavior.
  • I couldn’t reproduce the issue on Fx releases (64.0 - 20181205213546 and 64.0.2 -20190108160530).
  • See the Browser console content when the error is triggered: https://drive.google.com/open?id=1dyq0f2K0XrAD2Sh4LamkV3IV1WsN6Uqk

I forgot to mention the demo, on which the bug is reproducible: "Dig the Uke" by Stefan Kartenberg (audio only, multicodec, Widevine - https://shaka-player-demo.appspot.com/demo/#asset=https://storage.googleapis.com/shaka-demo-assets/dig-the-uke/dash.mpd;lang=en-US;build=uncompiled.

Rank: 15
Flags: needinfo?(alwu)
Priority: -- → P2

Shaka player bustage doesn't sound good. We've got our final 65 Beta build tomorrow before next week's RC. Nils, can you help make sure we get an owner assigned ASAP?

Flags: needinfo?(drno)

I'll start to take a look today, sorry for the delay.

Assignee: nobody → alwu
'NS_ERROR_DOM_MEDIA_WAITING_FOR_DATA' and 'NS_ERROR_DOM_MEDIA_CANCELED' are not the decoding error, so we should
also treat them specially like what we did for 'NS_ERROR_DOM_MEDIA_END_OF_STREAM'.
Flags: needinfo?(drno)
Flags: needinfo?(alwu)

NI jya for the question pending in Phabricator. This feels like a regression we don't want to ship in Fx65, but we're building the RC on Monday... :\

Flags: needinfo?(jyavenard)
Has Regression Range: --- → yes
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/413e705328be
handle non decoding errors when we seek back to the start position. r=jya
Flags: needinfo?(jyavenard)

Comment on attachment 9036991 [details]
Bug 1519317 - handle non decoding errors when we seek back to the start position.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1498440

User impact if declined: Shaka player won't be able to replay

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Reproduce steps is mentioned in comment0.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It doesn't introduce any new feature and logic, what we do here is not to return error and handle it properly so that the video can be replay again.

String changes made/needed: no

Attachment #9036991 - Flags: approval-mozilla-beta?

Anca, please verify that this is working as expected for you in Nightly builds containing the fix. Thanks!

Flags: qe-verify+
Flags: needinfo?(anca.soncutean)

I can confirm the fix with Fx 66.0a1 - 20190122232941 on Ubuntu 18.04 x64, macOS 10.13 and Windows 10 x64. Note that for Windows, I used the debug build, since the rest of the provided builds for this OS have the usercancel tag.

Flags: needinfo?(anca.soncutean)
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Comment on attachment 9036991 [details]
Bug 1519317 - handle non decoding errors when we seek back to the start position.

[Triage Comment]
Fixes a regression in the widely-used Shaka Player library. Approved for 65.0 RC2.

Attachment #9036991 - Flags: approval-mozilla-beta? → approval-mozilla-release+

This issue is verified as fixed with Fx 65.0 (20190124174741) and Fx 66.0a1 (20190125095457) on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.