Closed Bug 1519517 Opened 2 years ago Closed 11 months ago

Don't animate window maximize / resizes when restoring session

Categories

(Firefox :: Session Restore, defect, P2)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: mconley, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxperf:p2])

Attachments

(2 files)

STR:

  1. Configure Firefox to restore sessions on start-up
  2. Open a few windows, and maximize one of them (when I reproduced this bug, it was the last window I opened that I maximized)
  3. Quit the browser
  4. Start the browser

ER:

The windows from the last session should be opened, but none should animate.

AR:

The maximized window is opened, and then animates itself into the maximized state.

I only tried reproducing this on macOS, but this might also affect Windows and Linux.

Setting the [fxperf] flag because this is the sort of thing that can impact perceived start-up time.

(In reply to Mike Conley (:mconley) (:⚙️) from comment #0)

Setting the [fxperf] flag because this is the sort of thing that can impact perceived start-up time.

It does indeed, certainly on OSX. We do set dwu.suppressAnimation(true);, which I think you added, but it doesn't seem to do anything in Cocoa widget code.

Blocks: ss-perf
Priority: -- → P2

Not sure if related, but on my Windows 10 usually restoring a session opens Nightly as maximized, goes to unmaximized and then maximizes again.
I'm almost always using Nightly in a maximized state.

Whiteboard: [fxperf] → [fxperf:p2]
Assignee: nobody → emalysz
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9697456a48b3
ensure that restoring a session doesn't animate and resize the window r=mstange
OS: Unspecified → macOS
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: qe-verify+

I can't seem to be able to reproduce this issue.
Can you please post a gif with the issue or verify to see if the issue is reproducing on latest Nightly or beta?

Attached video Animate.mov
You need to log in before you can comment on or make changes to this bug.