Closed Bug 1519611 Opened 3 years ago Closed 3 years ago

no option for quit warning

Categories

(Firefox :: Preferences, defect)

64 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1506173

People

(Reporter: illumilor.e, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

in the preferences menu there is no option for a do you really want to quit warning with multiple tabs open

Actual results:

given there is a warning for opening multiple tabs there should a way to warn when closing tabs

Hi :illumilor.e,
It seems to me that you want an option in preferences to enable/disable quit warning when multiple tabs are open. This is already there.

To disable: When you have multiple tabs open and try to quit Firefox, the default behavior is that it shows you a warning dialog. If you look closely, there is an option(checkbox) in the warning dialog which you can unmark to disable the warning.

Next time it should no longer show you this warning box.

To enable: If the warning is disabled, then you can navigate to preferences page>general tab and now there is an option("Warn you when closing multiple tabs") to enable the warning again.
This option is not shown when the warning is enabled.

I am marking this as "Works for me". If my understanding of your issue is wrong, please feel free to reopen this bug. Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
QA Whiteboard: [triagemonth-2019-01]
Component: Untriaged → General
Resolution: --- → WORKSFORME

I have made sure that the warn when closing tabs is enabled, but firefox still just quits without any warning dialogue.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Could you please navigate to about:preferences#general, take a screenshot and attach here?

Flags: needinfo?(illumilor.e)
Component: General → Preferences

(In reply to illumilor.e from comment #2)

I have made sure that the warn when closing tabs is enabled, but firefox still just quits without any warning dialogue.

I'm assuming you have session restore enabled, or you've toggled browser.warnOnQuit to false in about:config .

For the former case, there is a checkbox in the prefs starting in Firefox 65 (currently in release candidate stage, release is next week).

I'm going to dupe this to the bug that added that checkbox.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1506173
You need to log in before you can comment on or make changes to this bug.