Closed Bug 1519855 Opened 1 year ago Closed 1 year ago

The server should support the BFCache

Categories

(DevTools :: Debugger, enhancement, P2)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: jlast, Assigned: bhackett1024)

References

(Blocks 4 open bugs)

Details

(Whiteboard: [debugger-mvp])

Attachments

(2 files, 1 obsolete file)

The client has some fragile logic to support the BFCache on navigation:

  1. wait 100ms
  2. fetch sources, if it has not received any sources yet

This fails for heavy sites or slow computers that load sites in > 100ms. It is also an implementation detail the client should not have to know about.

The server should support the BFCache case and always stream sources down to the client.

Severity: normal → enhancement
Priority: -- → P2
Blocks: dbg-68
No longer blocks: dbg-68
Whiteboard: [debugger-mvp]
Blocks: dbg-server

removing dbg-69 as we can work on this when we focus on dbg-source-requests

No longer blocks: dbg-sources
Blocks: dbg-sources
No longer blocks: dbg-69
Whiteboard: [debugger-mvp]
Blocks: dbg-70
Whiteboard: [debugger-mvp]
Whiteboard: [debugger-mvp] → [debugger-reserve]

This logic in the client is causing the last failure on try that is preventing bug 1538056 from landing. The problem is that when a page reloads, there is a window of time between when the client has been notified of the reload and when the server's new window finishes being created, at which point the server resets its sources information. If the client sends requests to the server in this time period, it gets info about the old sources but associates it with the new page. This is an existing problem but seems asymptomatic without bug 1538056. With bug 1538056, the sources information include HTML file contents, and the client can get stale data from those sources and show it to the user after reloading.

Fixing the server to handle the BFCache and removing this odd logic from the client seems like the best way to fix this. In particular, if the BFCache is being used and the client sends a request to get the sources before the window is ready, the client won't get the new sources from the server when they appear later on.

Blocks: 1538056
Assignee: nobody → bhackett1024
Status: NEW → ASSIGNED
Whiteboard: [debugger-reserve] → [debugger-mvp]
Attachment #9078934 - Attachment is obsolete: true
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f76e143931db
Notify client about sources after BFCache navigations, r=jdescottes.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.