Closed Bug 1520166 Opened 1 year ago Closed 1 year ago

Transition in-tree jcjones/u2f-hid-rs to vendoring mozilla/authenticator-rs v0.2.5

Categories

(Core :: DOM: Web Authentication, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox66 --- wontfix
firefox69 --- fixed

People

(Reporter: jcj, Assigned: eijebong)

References

Details

(Whiteboard: [webauthn][u2f])

Attachments

(2 files)

Primarily picking up https://github.com/jcjones/u2f-hid-rs/pull/75. Might want to wait until 67.

Component: DOM: Device Interfaces → DOM: Web Authentication
Assignee: nobody → jjones
Status: NEW → ASSIGNED
See Also: → 1548895
Summary: Upgrade u2f-hid-rs to v0.2.4 → Transition jcjones/u2f-hid-rs to mozilla/authenticator-rs v0.2.4

Anything new on this ? It's the last thing preventing the removal of rand 0.3. I'm not sure if doing it would be ok with you since you're assigned

Flags: needinfo?(jjones)

I haven't had time to pick this up, been busy with Fennec. I'll be getting it in this release, but I was hoping to also remove u2f-hid-rs from-tree and vendor-in authenticator-rs as part of it.

I just released 0.2.5 to crates.io for the purpose. If you'd like to take on swapping from in-tree to vendoring though before I get there, feel free to! Sorry for the delay.

https://crates.io/crates/authenticator

Flags: needinfo?(jjones)

No problem with the delay, I'll do it if I have some time before you do. I was just hesitant because the issue was assigned and I'm not familiar with the bugzilla customs

Fair enough. Consider this permission to take it -- it's assigned to me mostly as a reminder to Do It Do It Do It. :)

Summary: Transition jcjones/u2f-hid-rs to mozilla/authenticator-rs v0.2.4 → Transition in-tree jcjones/u2f-hid-rs to vendoring mozilla/authenticator-rs v0.2.5
Duplicate of this bug: 1544401
Duplicate of this bug: 1395293

This is now blocked on https://github.com/mozilla/authenticator-rs/pull/91

Other than that, everything went smoothly, I'll push my patch once 0.2.6 gets released

https://crates.io/crates/authenticator updated to 0.2.6 -- thank you!

Assignee: jjones → eijebong

This replaces the in-tree u2fhid (which has been renamed to
authenticator) by the published crate.

Pushed by eijebong@bananium.fr:
https://hg.mozilla.org/integration/autoland/rev/34d9d707fcd5
Part 1: Use a vendored version of authenticator. r=jcj
https://hg.mozilla.org/integration/autoland/rev/ad1be1252928
Part 2: revendor dependencies. r=jcj
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.