Incorrect MIME type crashes Mozilla

RESOLVED DUPLICATE of bug 141826

Status

Core Graveyard
Java: OJI
--
major
RESOLVED DUPLICATE of bug 141826
16 years ago
7 years ago

People

(Reporter: esnible, Assigned: Joe Chou)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If a user surfs to or enters the URL of a Java .class file Mozilla will crash if
the web server sends "application/x-java-vm" as the MIME type.  (If the MIME
type is "application/octet-stream" the browser will correctly download the
.class file.)

I have set my web server to send the bad MIME type.  Try to open
http://www.snible.org/fphover.class

I'm using RedHat 7.2 with "Java(TM) Plug-in 1.3.1_02-b02".

Comment 1

16 years ago
wfm: Win98 2002061408 JRE 1.4.0_01

Comment 2

16 years ago
This site uses fphover applet, which is known to crash JRE < 1.4.0.
Marking dupe of bug 57372.

Upgrade to JRE 1.4.0 and reopen bug report if you still experience a crash.

*** This bug has been marked as a duplicate of 57372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: crash
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
I will try upgrading to JRE 1.4 but this is NOT a duplicate of bug 57372!

*Any* Java class file crashes my Mozilla this way.  I merely discovered the
problem with fphover.  Here are two other applets, an IBM graphics viewer and a
game I wrote myself.  Neither is incompatible with any Java versions.

http://www.snible.org/media/hm35.class
http://www.snible.org/java/Water.class
(Reporter)

Comment 4

16 years ago
Furthermore, Mozilla crashes in the same way when the plugin is
/usr/java/j2re1.4.0_01/plugin/i386/ns610/libjavaplugin_oji.so .
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

16 years ago
I think you are seeing the browser version of bug 141826 (see the testcase
there).  Basically, the JRE plugin barfs if it is given something that is
misidentified as a java applet.

==> OJI
Assignee: beppe → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac
(Reporter)

Comment 6

16 years ago
I think you are correct and this is a duplicate of 141826.  However, in this
case it's a valid Java applet .class file.  I will join bug 141826 and see if I
can help there.

*** This bug has been marked as a duplicate of 141826 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.