Closed Bug 1520431 Opened 2 years ago Closed 2 years ago

The Videos are blocked from autoplaying on Facebook

Categories

(Core :: Audio/Video: Playback, defect)

Desktop
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox64 --- disabled
firefox65 --- disabled
firefox66 --- affected

People

(Reporter: rares.doghi, Unassigned)

References

Details

[Affected versions]:
Nightly 66.0a1

[Affected platforms]:
Platforms: Ubuntu

[Steps to reproduce]:

  1. Open the Firefox browser and reach about:preferences#privacy > Permissions section.
  2. Uncheck the "Block websites from automatically playing media with sound" option.
  3. Reach Facebook and login.
  4. Scroll until videos are in view.

Expected Result:
The Videos should play without sound since the Block autoplay feature is turned off.

Actual Results:
The Videos will not start until the user clicks them.

Note: This issue does not occur on Windows or Mac.
Please also note that on Ubuntu The Facebook settings for videos do not have the Option to turn Autoplay ON - OFF.

Alastor, can you triage this one as well? I don't have linux unfortunately.

Flags: needinfo?(alwu)

Sure, I'll take a look later, keep NI.

Apparently Facebook doesn't enable autoplay video on Ubuntu [1], and I also checked the log to confirm that the video didn't trigger autoplay when they were into view.

[1] https://drive.google.com/file/d/1SepMQptKJyBEynCoxwq8KRVB5qJiZ6An/view?usp=sharing

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.