Closed Bug 1520436 Opened 7 months ago Closed 7 months ago

The "X "button tooltip from Site Information panel refers to the removed doorhanger

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox64 --- disabled
firefox65 --- disabled
firefox66 --- affected

People

(Reporter: tbabos, Assigned: alwu)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

[Affected versions]:
Nightly 66.0a1

[Affected platforms]:
Windows 7/10 x64
Mac OS 10.13
Ubuntu 16.04

[Steps to reproduce]:

  1. Go to about:preferences#privacy
  2. Add "https://edition.cnn.com/videos" as an exception (Allow) in the Autoplay Exceptions list
  3. Go to https://edition.cnn.com/videos
  4. Check the Site Information panel
  5. Hover over the X button beside the "Allowed" label

[Expected]:
"Clear this permission" tooltip should be displayed or something similar.

[Actual Results]:
"Clear this permission and ask again" tooltip is displayed as it refers to the doorhanger which was removed.

Rank: 17
Flags: needinfo?(alwu)
Priority: -- → P2
Flags: needinfo?(alwu)
Assignee: nobody → alwu
As non-promptable permission won't prompt user to ask for their approval, we should use different texts for the cancel button of promptable permissions.
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10716b2122dc
part1 : add another tooltip text for non-promptable permission. r=flod,johannh
https://hg.mozilla.org/integration/autoland/rev/4752a33b4c3a
part2 : modify test. r=johannh
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1136af68ddae
Backed out 2 changesets for TV failures in browser/base/content/test/permissions/browser_permissions.js CLOSED TREE

Weird, I've pulled the latest m-c and test my patches again, the try result [1] looks very good. I'll reland them again.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=2cddb84a2edbe569ccb3e371113efe68aec2b8e1

Flags: needinfo?(alwu)
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1428560105ca
part1 : add another tooltip text for non-promptable permission. r=flod,johannh
https://hg.mozilla.org/integration/autoland/rev/031aee32565c
part2 : modify test. r=johannh

Backed out 2 changesets (bug 1520436) for browser-chrome failures in browser/base/content/test/permissions/browser_permissions.js

Log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=223532689&repo=autoland&lineNumber=3115

INFO - TEST-START | browser/base/content/test/permissions/browser_permissions.js
08:59:09 INFO - GECKO(879) | ++DOCSHELL 0x11d7d7000 == 3 [pid = 883] [id = {619b6633-78de-e44f-bd72-75f1278cb3d1}]
08:59:09 INFO - GECKO(879) | ++DOMWINDOW == 6 (0x11e65ec00) [pid = 883] [serial = 6] [outer = 0x0]
08:59:09 INFO - GECKO(879) | ++DOMWINDOW == 7 (0x11e667400) [pid = 883] [serial = 7] [outer = 0x11e65ec00]
08:59:09 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 125
08:59:09 INFO - GECKO(879) | ++DOMWINDOW == 8 (0x11e668c00) [pid = 883] [serial = 8] [outer = 0x11e65ec00]
08:59:09 INFO - GECKO(879) | --DOCSHELL 0x11c80d800 == 2 [pid = 881] [id = {f3699f09-8cfc-6746-9849-1d98784a52c5}]
08:59:09 INFO - GECKO(879) | --DOMWINDOW == 7 (0x1149da400) [pid = 881] [serial = 1] [outer = 0x0] [url = about:blank]
08:59:09 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:09 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:10 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:10 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:10 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:10 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:10 INFO - GECKO(879) | --DOMWINDOW == 2 (0x11adcb400) [pid = 885] [serial = 2] [outer = 0x0] [url = about:blank]
08:59:11 INFO - GECKO(879) | --DOCSHELL 0x11a714800 == 3 [pid = 880] [id = {c2742c6b-63ec-ca49-b1f6-abdd955652c8}]
08:59:11 INFO - GECKO(879) | --DOMWINDOW == 7 (0x1128adc00) [pid = 880] [serial = 4] [outer = 0x0] [url = moz-extension://d0cd6b60-f380-674d-91d5-bd442bd2352f/_generated_background_page.html]
08:59:11 INFO - GECKO(879) | ++DOCSHELL 0x12361a000 == 2 [pid = 885] [id = {6ca50eb4-fffe-4f49-801a-b3ca20003c77}]
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 3 (0x11adc9400) [pid = 885] [serial = 4] [outer = 0x0]
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 4 (0x122cd3000) [pid = 885] [serial = 5] [outer = 0x11adc9400]
08:59:11 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 125
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 5 (0x122cd7000) [pid = 885] [serial = 6] [outer = 0x11adc9400]
08:59:11 INFO - GECKO(879) | ++DOCSHELL 0x1249aa800 == 4 [pid = 883] [id = {8caedacb-fdaa-dc43-9293-4ec7b6d470b6}]
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 9 (0x11e66b000) [pid = 883] [serial = 9] [outer = 0x0]
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 10 (0x11e6dac00) [pid = 883] [serial = 10] [outer = 0x11e66b000]
08:59:11 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 125
08:59:11 INFO - GECKO(879) | ++DOMWINDOW == 11 (0x11e66b400) [pid = 883] [serial = 11] [outer = 0x11e66b000]
08:59:11 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:11 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:12 INFO - TEST-INFO | started process screencapture
08:59:12 INFO - TEST-INFO | screencapture: exit 0
08:59:12 INFO - Buffered messages logged at 08:59:09
08:59:12 INFO - Entering test bound testMainViewVisible
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | List of permissions is empty -
08:59:12 INFO - Buffered messages logged at 08:59:10
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | List of permissions is not empty -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | One permission visible in main view -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Correct value -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | There is an image for the permissions -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | proper class is in image class -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | List of permissions is empty -
08:59:12 INFO - Buffered messages logged at 08:59:11
08:59:12 INFO - Leaving test bound testMainViewVisible
08:59:12 INFO - Entering test bound testIdentityIcon
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | identity-box signals granted permissions -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | identity-box doesn't signal granted permissions -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | identity-box doesn't signal granted permissions -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | identity-box signals granted permissions -
08:59:12 INFO - Leaving test bound testIdentityIcon
08:59:12 INFO - Entering test bound testCancelPermission
08:59:12 INFO - Buffered messages logged at 08:59:12
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | List of permissions is not empty -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | One permission should be removed -
08:59:12 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | tooltip text for promptable permission is correct -
08:59:12 INFO - Buffered messages finished
08:59:12 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/permissions/browser_permissions.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_permissions.js:113 - TypeError: cancelButtons[1] is undefined
08:59:12 INFO - Stack trace:
08:59:12 INFO - testCancelPermission/<@chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_permissions.js:113:5
08:59:12 INFO - asyncwithNewTab@resource://testing-common/BrowserTestUtils.jsm:111:24
08:59:12 INFO - async
testCancelPermission@chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_permissions.js:88:9
08:59:12 INFO - AsyncTester_execTest/<@chrome://mochikit/content/browser-test.js:1108:34
08:59:12 INFO - async
Tester_execTest@chrome://mochikit/content/browser-test.js:1099:16
08:59:12 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:997:9
08:59:12 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
08:59:12 INFO - Leaving test bound testCancelPermission
08:59:12 INFO - Entering test bound testPermissionHints
08:59:12 INFO - GECKO(879) | ++DOCSHELL 0x12367e800 == 3 [pid = 885] [id = {e2ba03fd-8df0-704e-bb03-f19b0c925db3}]
08:59:12 INFO - GECKO(879) | ++DOMWINDOW == 6 (0x123f3b800) [pid = 885] [serial = 7] [outer = 0x0]
08:59:12 INFO - GECKO(879) | ++DOMWINDOW == 7 (0x124bea000) [pid = 885] [serial = 8] [outer = 0x123f3b800]
08:59:12 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 125
08:59:12 INFO - GECKO(879) | ++DOMWINDOW == 8 (0x124bea800) [pid = 885] [serial = 9] [outer = 0x123f3b800]
08:59:12 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:12 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:13 INFO - GECKO(879) | --DOMWINDOW == 2 (0x11b8aa400) [pid = 887] [serial = 2] [outer = 0x0] [url = about:blank]
08:59:13 INFO - Not taking screenshot here: see the one that was previously logged
08:59:13 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/permissions/browser_permissions.js | Empty hint is visible -
08:59:13 INFO - Stack trace:
08:59:13 INFO - chrome://mochikit/content/browser-test.js:test_ok:1307
08:59:13 INFO - chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_permissions.js:testPermissionHints/<:133
08:59:13 INFO - resource://testing-common/BrowserTestUtils.jsm:withNewTab:111
08:59:13 INFO - chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_permissions.js:testPermissionHints:126
08:59:13 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1108
08:59:13 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1099
08:59:13 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
08:59:13 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Reload hint is hidden -
08:59:13 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:13 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Empty hint is hidden -
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Reload hint is hidden -
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Empty hint is hidden -
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Reload hint is visible -
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Empty hint is hidden -
08:59:13 INFO - TEST-PASS | browser/base/content/test/permissions/browser_permissions.js | Reload hint is visible -
08:59:13 INFO - GECKO(879) | [Child 885, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/Element.cpp, line 1261
08:59:13 INFO - GECKO(879) | --DOMWINDOW == 7 (0x11adc8800) [pid = 885] [serial = 1] [outer = 0x0] [url = https://example.com/browser/browser/base/content/test/permissions/browser_autoplay_blocked.html]
08:59:13 INFO - GECKO(879) | --DOCSHELL 0x122c0e800 == 2 [pid = 885] [id = {58b1c014-4426-054c-ad52-ba0aba9f338e}]
08:59:13 INFO - GECKO(879) | [Child 885, Main Thread] WARNING: Can't add a range if the end is older that the start.: file /builds/worker/workspace/build/src/dom/html/TimeRanges.cpp, line 73
08:59:13 INFO - GECKO(879) | --DOMWINDOW == 2 (0x11cdc8400) [pid = 884] [serial = 2] [outer = 0x0] [url = about:blank]
08:59:13 INFO - GECKO(879) | ++DOMWINDOW == 8 (0x122cd6800) [pid = 885] [serial = 10] [outer = 0x123f3b800]
08:59:13 INFO - GECKO(879) | --DOMWINDOW == 6 (0x11a7d4000) [pid = 880] [serial = 12] [outer = 0x0] [url = moz-extension://d0cd6b60-f380-674d-91d5-bd442bd2352f/_generated_background_page.html]
08:59:13 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 165
08:59:13 INFO - GECKO(879) | [Parent 879, Main Thread] WARNING: '!mPresContext', file /builds/worker/workspace/build/src/dom/events/UIEvent.cpp, line 179
08:59:14 INFO - GECKO(879) | --DOMWINDOW == 6 (0x11c8cc000) [pid = 881] [serial = 4] [outer = 0x0] [url = about:blank]
08:59:14 INFO - GECKO(879) | --DOMWINDOW == 5 (0x11c8c6400) [pid = 881] [serial = 3] [outer = 0x0] [url = about:blank]
08:59:14 INFO - Not taking screenshot here: see the one that was previously logged
08:59:14 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/permissions/browser_permissions.js | Empty hint is visible after reloading -

Push with failres:
https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=031aee32565cbe411a7153eaf483dd6d3f8c2bbf

Backout:
https://hg.mozilla.org/integration/autoland/rev/c6bcb29d01655d59b3e5cd496bb351fa92389b12

Flags: needinfo?(alwu)

Ah, we don't need this change anymore, because we have replaced the cancel button to dropdown list in bug1517526. I'll close this bug.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(alwu)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.