Closed Bug 1520607 Opened 9 months ago Closed 9 months ago

If you add several of the Page Actions menu items to the addressbar, Page Actions pop-up menu does not stay aligned with Page Actions button

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 66
Tracking Status
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- verified

People

(Reporter: asa, Assigned: Gijs)

References

Details

Attachments

(3 files)

Attached image image.png

If you add several of the Page Actions menu items to the addressbar, Page Actions pop-up does not stay aligned with Page Actions button. If you only add one item, the Page Actions pop-up menu does shift left to stay aligned with the Page Actions button. But if you add more, it stops moving left and becomes unaligned. Screenshot will hopefully make it obvious what I'm trying to explain

(In reply to Asa Dotzler [:asa] from comment #0)

Created attachment 9037039 [details]
image.png

If you add several of the Page Actions menu items to the addressbar, Page Actions pop-up does not stay aligned with Page Actions button. If you only add one item, the Page Actions pop-up menu does shift left to stay aligned with the Page Actions button. But if you add more, it stops moving left and becomes unaligned. Screenshot will hopefully make it obvious what I'm trying to explain

Not as much as a screencast, unfortunately... does the popup stay open when you add an item? It doesn't for me (beta, mac)... what OS? What version? Can you check if this is a regression?

Flags: needinfo?(asa)

Testing the latest nightly build on Windows 10 on Intel.

The menu stays open as I add items to the address bar. When I add the first item, the menu moves to the left and stays connected to the ... button but as I add more items, the menu stops moving left and so is no longer connected to the ... button.

I tried making a screen recording but the menu didn't show up at all. My screen recording app (Windows Gamebar) must think the pop-up menu is a different window or something. I'll try to find some other software or take a video with my phone.

Flags: needinfo?(asa)

In the attached video, you can see that when I add the first item to the addressbar the ... button and the menu both shift left to accommodate the added addressbar button. When I add additional buttons to the addressbar, however, the menu stays put, becoming detached from the ... button. I hope this makes things a little more clear than the screenshot.

Neil, do you know why initially, the popup/panel moves, but not the second/third/nth time we move the anchor?

Flags: needinfo?(enndeakin)

At some point when 'Add to Address Bar' is selected, the line at:

https://searchfox.org/mozilla-central/source/browser/components/customizableui/PanelMultiView.jsm#1114

clears the autoPosition on the panel, preventing the panel from updating automatically. The line exists within a popuppositioned event listener which is presumably being called because the popup has moved after the anchor button has shifted.

Flags: needinfo?(enndeakin)

We can presumably only set the autoposition prop when we are in the process of showing subviews after the panel is initially opened, so as to avoid it being set when we do actually move the anchor.

I'm not 100% sure this doesn't cause other regressions, given bug 941196 comment 15, but at least with some casual testing I didn't see any issues... Mike, I'll make sure to ask you for review. This was moved in bug 1412364 so hopefully between you and sfoster you can cover some of the history / known edgecases here. :-)

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
See Also: → 1412364, 941196
Priority: -- → P3
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2e27f3f1ebc6
only disable and re-enable autopositioning while in the process of showing subviews, r=sfoster,mconley
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

I have reproduced this bug with Nightly 66.0a1 (2019-01-16) on Windows 7, 64 Bit! This bug's fix is verified with latest Nightly!

Build ID : 20190128092811
User Agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

QA Whiteboard: bugday-20190123]

Thank you Mohammad for verifying this!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.