All users were logged out of Bugzilla on October 13th, 2018

question marks instead of cyrillics in all window titles

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
17 years ago
12 years ago

People

(Reporter: cubeover, Assigned: nhottanscp)

Tracking

({intl})

Trunk
Future
All
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I see question marks instead of cyrillics in all window titles SUBJ. NN 4.79
shows cyrillics, as well as MS products. MacOS 9.2.2 + Apple Cyrillic Langueg Kit.

Updated

17 years ago
Blocks: 104320

Comment 1

17 years ago
nhotta: if you know of duplicate of this bug; please mark as such.
over to nhotta, cc ftang
Assignee: yokoyama → nhotta
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → kasumi
(Assignee)

Comment 2

17 years ago
MacOS X does not have the problem.
We could do some workaround for language kit.
Set to Future for now.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
Recent build still have this problem. (tested ID=2002081908)
(Reporter)

Comment 4

16 years ago
Now NC 7.0 has this bug, too. He-he. Unusable for whole bunch of Russia maccies.

Comment 5

16 years ago
I see this problem on Win2K build 20021007. 
Default locale is set to US English (with Eastern European langauges pack
enabled ). 
IE shows all titles correctly.

Comment 6

16 years ago
Related: bug 104934 comment #59  (yes, there's something about MacOS) or maybe
even fixed (at least on Win2k, see comment #5) by turning Mozilla into an
unicode application?

Comment 7

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

15 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 8

15 years ago
This has been solved on Windows 2k/XP and Linux (UTF-8) locale(bug 9449). (as
noted earlier, it's not an issue on Mac OS X). It cannot be solved and won't be
solved on Win 9x/ME. In case of MacOS classic, a work-around is to use a utility
('script switcher') to set the 'locale' of Mozilla to the one whose charset
covers Cyrillic(i.e. MacCyrillic). 
OS: All → Mac System 9.x

Comment 9

15 years ago
Since this is Mac OS Classic only, I'm marking this WONTFIX, since this platform
isn't supported anymore.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.