Closed Bug 1520914 Opened 2 years ago Closed 2 years ago

New System : Blank page persists after "enable" toggle is turned on

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.4 - Jan 21 - 27
Tracking Status
firefox66 --- fixed

People

(Reporter: bnagabandi, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

about:newtab#devtools-ds goes blank after turning ON the toggle "enabled" switch.
This happens only for the very first time on the system (Mac/Windows) , and the next time when toggled ON/OFF, page is not blank. (cached)

Steps to Reproduce:

  1. Set browser.newtabpage.activity-stream.asrouter.devtoolsEnabled to true in about:config
  2. Visit about:newtab#devtools-ds. Ensure you see devtools
  3. Try turning ON the new tab experiment off/on via the "enabled" checkbox

Actual Result:
about:newtab#devtools-ds goes blank

Expected Result:
Blank page not expected.

cc: @Kate Hudson :k88hudson

Assignee: nobody → pdahiya

On debugging looks like render is failing when feeds[feed.url] is undefined

https://github.com/mozilla/activity-stream/blob/master/content-src/components/ASRouterAdmin/ASRouterAdmin.jsx#L71

Error in console:
Dispatch error: TypeError: feeds[feed.url] is undefined

Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/108b37488788f64ef905c797d1bd7a879e835a3c
Bug 1520914 - AS devtools blank page fix on first discovery stream enable (#4687)
Keywords: github-merged
Iteration: --- → 66.4 - Jan 21 - 27
Priority: -- → P1
Blocks: 1521836
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

QA Results :

Created a new profile and checked on Mac and Windows 10 Pro.

No more blank page.

Closing as verified.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.