Compaction removed all mail in inbox and deleted several folders

VERIFIED DUPLICATE of bug 173357

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 173357
16 years ago
13 years ago

People

(Reporter: Jim McQueeney, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({dataloss})

Trunk
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

After allowing automatic folder compaction I found that all my inbox mail was
gone (150 messages, all unread), my sent mail folder was empty (about 1000
messages) and several of my other folders (various number of messages in each)
were completely missing. 

Reproducible: Sometimes
Steps to Reproduce:
1. ???
2.
3.

Expected Results:  It should have preserved my folders and included messages!

Updated

16 years ago
Severity: normal → critical
Keywords: dataloss

Updated

16 years ago
QA Contact: olgam → sheelar
(Reporter)

Comment 1

16 years ago
To add to this, a few days ago I found some 'ghost' messages in my otherwise
empty inbox. I could not remove them; everytime I deleted them they would come
back when I moved to a different folder and then back to the inbox. Being
curious, I took a look at the 'inbox' file with 'Notepad' and found it was full
of messages that weren't showing up in the Mozilla inbox window (the file was
17.7 megs!). I wrote a small utility to extract the individual files and
discovered that there were 3636 messages in the file. I am retaining copies of
the inbox and inbox.msf files should you care to examine them. Since then, I
have created new inbox and inbox.msf files and things seem to be working
correctly again...

Jim McQueeney <jajom@lava.net> 

Comment 2

15 years ago
I think this bug is same: Bug 137139

Comment 3

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910

I can confirm this bug.
I compacted my all folders and then my Inbox become empty.

I used "Compact This Folders". When the Mozilla was working I started some new
"Compact This Folders" process.
Later I watched my c:\...\Users50\MozProfile\...\Mail\pop.tvnet.hu folder. There
was an Inbox.msf file (1295 byte), but nowhere was Inbox file.
I restarted my Mozilla then I saw an Inbox file (0 byte).

It's a very serious bug.
I lost some e-mails.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 173357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
verified 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.