Simplify CSS variables for icon colors

RESOLVED FIXED in Firefox 66

Status

enhancement
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: fvsch, Assigned: fvsch)

Tracking

unspecified
Firefox 66

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

We're using the same icon colors outside of toolbars too, so let's make it official and try to cut down on code that uses slightly different colors for icons.

Related: https://github.com/devtools-html/debugger.html/issues/7743

Assignee: nobody → florens
Status: NEW → ASSIGNED
  • Remane --theme-toolbar-icon-color to just --theme-icon-color
  • Rename --theme-toolbar-checked-color to --theme-icon-checked-color
  • Introduce a --theme-icon-alt-color that is less contrasted (e.g. for Rules icon buttons)
  • Avoid partial opacity variants of Photon Grey as global variables in variables.css
Attachment #9037818 - Attachment description: Bug 1521340 - Simplify icon color CSS variables; r=gl → Bug 1521340 - Simplify icon color CSS variables; r=ntim
Summary: Rename --theme-toolbar-icon-color CSS variable to --theme-icon-color → Simplify CSS variables for icon colors
Pushed by florens@fvsch.com:
https://hg.mozilla.org/integration/autoland/rev/d5962d1b5b32
Simplify icon color CSS variables; r=ntim
Duplicate of this bug: 1520257
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.