Closed Bug 1521440 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Blank page when reloading about:devtools-toolbox with WebConsole

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: jdescottes, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

STRs:

  • open about:debugging-new
  • click on inspect for any tab
  • in the newly opened about:devtools-toolbox, select the WebConsole
  • reload the about:devtools-toolbox tab (either keyboard shortcut, reload button, etc...)

ER: about:devtools-toolbox should be reloaded
AR: navigates to about:blank

Note that this also happens on other tools, if the split console is activated.
It seems to also happen for the memory tool. Also simply selecting the console once and then moving to another tool will trigger the issue.

Priority: -- → P2
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
Attachment #9040300 - Attachment is obsolete: true
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/954c0eef1bf3
Avoid to move to about:blank after destroying. r=ochameau,jdescottes
https://hg.mozilla.org/integration/autoland/rev/32dc2acf55bd
Add test for reloading about:devtools-toolbox. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/cc4ff64296c3
Add a test for hostType into browser_toolbox_target. r=ochameau
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

This issue is still reproducible.
Logged a new bug for it -> Bug 1539071.

You need to log in before you can comment on or make changes to this bug.