Closed Bug 1521501 Opened 10 months ago Closed 6 months ago

Restart browser is required in order to attribute a different extension: Return to AMO

Categories

(Firefox :: Messaging System, defect, P3, minor)

66 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox66 --- affected

People

(Reporter: vlad.jiman, Assigned: andreio)

References

(Blocks 1 open bug)

Details

Steps to reproduce:

  1. Using a Nightly build go to about:config and set the following prefs:
    browser.newtabpage.activity-stream.asrouter.devtoolsEnabled = true
    browser.newtabpage.activity-stream.asrouter.providers.onboarding set to:
    {"id":"onboarding","type":"local","localProvider":"OnboardingMessageProvider","enabled":true,"exclude":[]}
  2. Go to about:newtab#asrouter, Targeting tab and scroll to the bottom of the page
  3. Select Force Attribution and open a new tab with about:welcome url

Expected:
Upon going to about:welcome, the first page of return to amo page should be shown (+ Add the Extension)

Actual:
Restart is required each time we change the attribution, there is a high chance that this issue will not manifest in prod because only one extension will be attributed, thus the low priority.

Assignee: nobody → andrei.br92
Blocks: 1468680

This is used for testing purposes only so assigning lower priority.

Component: General → Activity Streams: Newtab
Priority: -- → P3
Product: WebExtensions → Firefox

I don't see any benefits from fixing this bug, the purpose of the router devtools is to get the message to show in order to test that it matches the design spec. Other functionality should be tested by simulating the real user action.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.