automatic form filler (password pair) should not fill in non-blank fields

VERIFIED DUPLICATE of bug 112260

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 112260
16 years ago
9 years ago

People

(Reporter: Jean-Marc Wislez, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I ran into the situation that I had accidentally a password pair registered
for a webpage where I administer user accounts of a web site.  From that
moment on, I was unable to do the administration properly, since the name
of the stored user always appeared in the fields, instead of that of the
user I wanted to edit.  
This, in practice, the html-code said <input type="text" name="name"
value="John">, but the screen showed "Tom" in that field.  

I suggest that, when a value is set in het html-code, the password manager
would not be activated.
we have one for that...
Whiteboard: DUPME

Comment 2

15 years ago
This is a bug. A value is set for 'username' in the html, but the password
manager changed it to the login name. Tested on mozilla 1.1 windows 98se. IE6
does not have this problem, so it is not the website's fault.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 112260 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPME
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
You need to log in before you can comment on or make changes to this bug.