The Autoplay media with sound shows BLOCKED when the feature is turned off

VERIFIED FIXED in Firefox 66

Status

()

defect
P2
normal
Rank:
15
VERIFIED FIXED
7 months ago
5 months ago

People

(Reporter: rares.doghi, Assigned: daleharvey)

Tracking

(Blocks 1 bug, {regression})

Trunk
Firefox 67
Desktop
Unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 disabled, firefox65 disabled, firefox66 verified, firefox67 verified, firefox68 verified)

Details

Attachments

(3 attachments)

[Affected versions]:
Nightly 66.0a1 Build ID: 20190123070847

[Affected platforms]:
Platforms: ALL

[Steps to reproduce]:

  1. Open the Firefox browser and reach https://edition.cnn.com/videos
  2. Reach Preferences in a new tab and uncheck the Global preference for "Block Websites from automatically playing media with sound"
  3. Reach the first tab and click the Home button in order to reach the homepage.
  4. Click the Back button in order to reach https://edition.cnn.com/videos and refresh the page

Expected Result:
The Crossed off play icon should not be displayed since the feature is turned off.
The You have not granted this site any special permissions should be displayed instead of the Automatically play media with sound - Block

Actual Results:
The Automatically play media with sound - Block and the Crossed off Play icon is displayed when the feature is turned off.

Posted image imgpsh_fullsize.png
Rank: 15
Priority: -- → P2

Hi, Dale,
Do you mind take a look for this one?
Thanks.

Component: Audio/Video: Playback → Site Identity and Permission Panels
Flags: needinfo?(dharvey)
Product: Core → Firefox

This is expected, we will show the user if autoplay is blocked regardless of whether they are blocked by default or not, otherwise there would be no way for them to know if a site is broken or not

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(dharvey)
Resolution: --- → INVALID

This issue only occurs in a particular case, I do not think this bug is invalid, if the user deactivates the Global preference and reaches any website, the Crossed off play icon and the info from the site information panel are not Shown since nothing is blocked, but if you reach cnn.com/videos when the feature is activated it will show the Blocked icon, then reach preferences and disable the global preference, reach the previous tab and change the website, then click the back button.

The Video Starts autoplaying because the feature is turned off but the Blocked Icon and info is still displayed even after refresh. Please check the new attachment video.

Please also note that when the feature is turned OFF the crossed off Blocking icon is NOT displayed and the site information panel always shows "You have not granted this site any special permissions".

Ah sorry I misunderstood the STR, yup I can reproduce this now, looking into it

Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Its best not to think of the feature being turned on / off, the feature to let users block autoplay videos is always on, what the checkbox does is change whether autoplay videos are allowed by default or not

Assignee: nobody → dharvey

dale did you already fix this one but didn't update the bug?
i tried to reproduce and it looks like it's fixed already.

Flags: needinfo?(dharvey)
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10ff993159a1
Fix race in clearing global permissions. r=johannh
Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment on attachment 9047087 [details]
Bug 1522058 - Fix race in clearing global permissions. r=johannh

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Confusing display of blocking autoplay icon
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch covered by automated tests
  • String changes made/needed:
Flags: needinfo?(dharvey)
Attachment #9047087 - Flags: approval-mozilla-beta?

Comment on attachment 9047087 [details]
Bug 1522058 - Fix race in clearing global permissions. r=johannh

Fix for autoplay icon display bug, OK for beta 13 uplift.

Attachment #9047087 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, This issue no longer occurs in Firefox release 66.0.2, Nightly 68 or Beta 67.0b6. I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.