Closed Bug 1522065 Opened 2 years ago Closed 2 years ago

The Autoplay Media with sound BLOCK option will remove the URL from the Exceptions list instead of changing its status

Categories

(Firefox :: Site Identity, defect, P2)

Desktop
Unspecified
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox64 --- disabled
firefox65 --- disabled
firefox66 --- affected

People

(Reporter: rares.doghi, Unassigned)

References

Details

[Affected versions]:
Nightly 66.0a1 - 20190123070847

[Affected platforms]:
Platforms: ALL

[Steps to reproduce]:

  1. Open the Firefox browser and reach https://edition.cnn.com/videos
  2. Open the Site info Panel and Allow Autoplay media with sound.
  3. Check the Preferences > Permissions > Exceptions list for Autoplay media with sound (Cnn.com is added with the Allow status)
  4. In the Previous tab Reach the site info panel and Block the Autoplay media with sound
  5. Reach Preferences > Permissions > Exceptions list for Autoplay media with sound

Expected Result:
The Site info panel should change the status of the domain from ALLOW to BLOCK in the Preferences > Permissions > Exceptions list for Autoplay media with sound

Actual Results:
The Previously added Domain with the ALLOW status is completely removed instead of changing its status to Blocked

Rank: 15
Priority: -- → P2

Hi, Dale,
Do you mind take a look for this one?
Thanks.

Component: Audio/Video: Playback → Site Identity and Permission Panels
Flags: needinfo?(dharvey)
Product: Core → Firefox

So I was actually planning to file a follow up to change to this behaviour as I assumed we would change it to BLOCK, however if a user changes the permission to match the default would should remove the permission and not duplicate it with default values

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dharvey)
Resolution: --- → INVALID

Hi, I thought the purpose of that Site information BLOCK/ALLOW button was to reflect the users choice of Blocking or Allowing a website to autoplay media with sound, that being said I think it should have priority over any other settings the user had in the about:preferences > Permissions section, regardless of the Exceptions he manually added to the list.

Since the functionality for the about:preferences > Permissions > Block Media with sound > Exceptions is that when you add the same website with a different status it just changes the status instead of removing the exception entirely, it should behave the same from the Site information panel specially since it reflects the user's choice.

It does not matter if the user disabled the Global Preference altogheter if he manually Blocked or Allowed media with sound it should take priority over any other settings, and the exceptions list should not change until the user feels otherwise.

Plus there is also the case where the user disables the Block autoplay feature but would still like to block some websites when he reaches them, option that is no longer possible from the site info panel , only if he reaches about:preferences > Permissions > Exceptions list.

In this case when the user Allows or Blocks a website from playing from the Site information panel and the Website is removed from the exceptions list, if he disables the feature at a later time he has no way of knowing why the websites he manually blocked are no longer blocked from playing media with sound, that is why the exceptions list should take priority over any other settings when a user's choice is involved and it should reflect those choices from the Site information panel.

Similiarly if we add a ALLOW exception in this case when the user just wanted to let the video autoplay for now and when they change the default in future and are confused why all these old sites can autoplay

Its a judgement call, not 100% either way however very much leaning towards consistency here, this isnt something we decided for block autoplay this is how the permissions already work, popup blocking shows the exact same behaviour and for the rest of the permissions its much clearer that when you click x you are removing the exception, the dropdown in this case could be clearer, but that would be a more general bug, not specific for autoplay

Yes but as long as its there in the exceptions list the Site info Panel will always show the current status with ALLOW or BLOCK and the user is free to change it, but when its removed from the exceptions list because the Global preference was unchecked the user will not even see the option to block it again from the site info panel.

Yup, the primary use case for the UI is to allow users to 'fix' sites that may get 'broken' due to the change in default behaviour, we arent looking to just add more points of configurability.

If users want to allow all autoplay except a few sites, they do it through about:preferences, that isnt a use case we are worried about optimising

You need to log in before you can comment on or make changes to this bug.