Consider sharing more information about fonts across processes

RESOLVED DUPLICATE of bug 1514869

Status

()

enhancement
RESOLVED DUPLICATE of bug 1514869
3 months ago
3 months ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox66 affected)

Details

(Reporter)

Description

3 months ago

It seems to me that content processes duplicate a lot of work that has to do with getting information about fonts:

  • Which fonts are available on the system
  • Which fonts support which characters
  • Font metrics

These font queries show up in profiles all the time. Could we share some of this information so that

  1. the time cost of looking up this information only needs to be paid once, and
  2. the memory cost of storing this information is only paid once?

Are there any existing plans to do this, or parts of this?

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1514869
(Reporter)

Comment 2

3 months ago

Woohoo!

You need to log in before you can comment on or make changes to this bug.