Closed Bug 1522302 Opened 11 months ago Closed 10 months ago

ARM64: Crash in wasm/tables.js

Categories

(Core :: JavaScript Engine: JIT, defect, P2)

ARM64
Unspecified
defect

Tracking

()

RESOLVED DUPLICATE of bug 1522298
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- affected

People

(Reporter: sstangl, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [arm64:m3])

When run on ARM64 hardware, this test fails: wasm/tables.js

The arguments passed are as follows:

--ion-eager --ion-offthread-compile=off --more-compartments wasm/tables.js
--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads wasm/tables.js

The crash signature is as follows:

Thread 1 "js" received signal SIGILL, Illegal instruction.
0x00002e9dd56480f4 in ?? ()
(gdb) x/8i $pc-12
   0x2e9dd56480e8:	ldr	x23, [x8, #8]
   0x2e9dd56480ec:	cmp	w23, #0x0
   0x2e9dd56480f0:	b.ne	0x2e9dd56480f8  // b.any
=> 0x2e9dd56480f4:	.inst	0xd4a00000 ; undefined
   0x2e9dd56480f8:	ldr	x21, [x23]
   0x2e9dd56480fc:	ldr	x11, [x23, #32]
   0x2e9dd5648100:	ldr	x9, [x23, #24]
   0x2e9dd5648104:	str	x9, [x11, #136]
See Also: → 1522303

[arm64:m3] because we should fix reproducible test crashes before letting ARM64 Fennec Nightly ride the trains to Beta.

Keywords: crash
Whiteboard: [arm64:m3]
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1522298
You need to log in before you can comment on or make changes to this bug.