Closed Bug 1522305 Opened 3 years ago Closed 3 years ago

Make MediaRecorder.start() timeslice parameter unsigned

Categories

(Core :: Audio/Video: Recording, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: mcasas, Assigned: pehrsons)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Expected results:

@ https://github.com/mozilla/gecko-dev/blob/master/dom/webidl/MediaRecorder.webidl#L41

because
https://github.com/w3c/mediacapture-record/issues/155

Status: UNCONFIRMED → NEW
Component: Untriaged → Audio/Video: Recording
Ever confirmed: true
Product: Firefox → Core
Assignee: nobody → apehrson
Status: NEW → ASSIGNED
Rank: 25
Priority: -- → P3

This currently sits late in a long queue of patches that are not ready to land yet. I don't think it goes cleanly onto m-c. Will push when everything is ready, or if I rebase and run tests before then.

Keywords: checkin-needed

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:pehrsons, could you have a look please?

Flags: needinfo?(apehrson)

I'll get to this in due time.

Flags: needinfo?(apehrson)
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c80dad655567
Make MediaRecorder timeslice parameter unsigned. r=jib,smaug
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.