Closed Bug 152243 Opened 19 years ago Closed 19 years ago

Mozilla should support line breaks in IMG title atribute

Categories

(Core :: Layout, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 67127

People

(Reporter: zbraniecki, Assigned: attinasi)

Details

Mozilla should support line breaks in TITLE atributes. At now Opera ignores it,
IE supports well, and Mozilla shows blind signs.

Title is used to write description for image. Sometime this description can be
very long (like in galleries) and title is very effective, non-scriptting, way
make it.

I'm not shure if it's a bug so i decided to put this as enhancement...
Whiteboard: DUPEME
This also affects TITLE attributes in links.

According to HTML 4.01, "User agents should interpret attribute values as follows:

    * Replace character entities with characters,
    * Ignore line feeds,
    * Replace each carriage return or tab with a single space."

So, IE does again things that are not according to the specification, but it
tries to deliver the intended output. Mozilla displays special characters
instead, which is definitely wrong. In my opinion, the browser should work
according to the specs, and reflow the text if it is too long.
->layout
Assignee: pavlov → attinasi
Component: Image: Layout → Layout
QA Contact: tpreston → petersen
I believe this bug duplicates bug #45375.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.