Intermittent js/src/jit-test/tests/binast/nonlazy/gc/bug-1214781.binjs | uncaught exception: out of memory (code 3, args "--baseline-eager") [0.4 s]

RESOLVED FIXED in Firefox 66

Status

()

defect
P5
normal
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: intermittent-bug-filer, Assigned: arai)

Tracking

({intermittent-failure})

unspecified
mozilla66
Points:
---

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(2 attachments)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=223736051&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/WYhuV5qcRLO_OzDcVjoV4Q/runs/0/artifacts/public/logs/live_backing.log

[task 2019-01-24T13:24:28.074Z] TEST-PASS | js/src/jit-test/tests/binast/nonlazy/gc/bug-1214006.binjs | Success (code 0, args "") [0.6 s]
[task 2019-01-24T13:24:28.075Z] {"action": "test_start", "jitflags": "", "pid": 27304, "source": "jittests", "test": "binast/nonlazy/gc/bug-1214006.binjs", "thread": "main", "time": 1548336267.473665}
[task 2019-01-24T13:24:28.075Z] {"action": "test_end", "extra": {"jitflags": "", "pid": 27304}, "jitflags": "", "message": "Success", "pid": 27304, "source": "jittests", "status": "PASS", "test": "binast/nonlazy/gc/bug-1214006.binjs", "thread": "main", "time": 1548336268.0673}
[task 2019-01-24T13:24:28.110Z] uncaught exception: out of memory
[task 2019-01-24T13:24:28.110Z] (Unable to print stack trace)
[task 2019-01-24T13:24:28.110Z] Exit code: 3
[task 2019-01-24T13:24:28.110Z] FAIL - binast/nonlazy/gc/bug-1214781.binjs
[task 2019-01-24T13:24:28.110Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/binast/nonlazy/gc/bug-1214781.binjs | uncaught exception: out of memory (code 3, args "--baseline-eager") [0.4 s]
[task 2019-01-24T13:24:28.111Z] {"action": "test_start", "jitflags": "--baseline-eager", "pid": 27354, "source": "jittests", "test": "binast/nonlazy/gc/bug-1214781.binjs", "thread": "main", "time": 1548336267.746787}
[task 2019-01-24T13:24:28.111Z] {"action": "test_end", "extra": {"jitflags": "--baseline-eager", "pid": 27354}, "jitflags": "--baseline-eager", "message": "uncaught exception: out of memory", "pid": 27354, "source": "jittests", "status": "FAIL", "test": "binast/nonlazy/gc/bug-1214781.binjs", "thread": "main", "time": 1548336268.107023}
[task 2019-01-24T13:24:28.111Z] INFO exit-status : 3
[task 2019-01-24T13:24:28.111Z] INFO timed-out : False
[task 2019-01-24T13:24:28.111Z] INFO stderr 2> uncaught exception: out of memory
[task 2019-01-24T13:24:28.111Z] INFO stderr 2> (Unable to print stack trace)
[task 2019-01-24T13:24:28.129Z] TEST-PASS | js/src/jit-test/tests/binast/nonlazy/gc/bug-1214006.binjs | Success (code 0, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.6 s]
[task 2019-01-24T13:24:28.129Z] {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "pid": 27314, "source": "jittests", "test": "binast/nonlazy/gc/bug-1214006.binjs", "thread": "main", "time": 1548336267.5025709}
[task 2019-01-24T13:24:28.129Z] {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "pid": 27314}, "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "message": "Success", "pid": 27314, "source": "jittests", "status": "PASS", "test": "binast/nonlazy/gc/bug-1214006.binjs", "thread": "main", "time": 1548336268.122902}

Arai, have you encountered this in your tests?

Flags: needinfo?(arai.unmht)

it's reproducible for me, both with binast/nonlazy/gc/bug-1214781.binjs and gc/bug-1214781.js
so this is not specific to BinAST.

then, it fails while JIT compiling the code.
if it's expected to fail like that, adding 'allow-oom' instead of 'allow-unhandlable-oom' will solve.

the directive of the original JS file is copied to the following 2 files
https://searchfox.org/mozilla-central/source/js/src/jit-test/tests/binast/lazy/gc/bug-1214781.dir
https://searchfox.org/mozilla-central/source/js/src/jit-test/tests/binast/nonlazy/gc/bug-1214781.dir

Flags: needinfo?(arai.unmht)
Assignee: nobody → arai.unmht
Status: NEW → ASSIGNED
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/5653b13f5b38
Allow normal OOM in gc/bug-1214781.js. r=bbouvier
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1520954
You need to log in before you can comment on or make changes to this bug.