Closed Bug 1522565 Opened Last year Closed Last year

Create a sub-panel for cryptominers and fingerprinters

Categories

(Firefox :: Site Identity, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: johannh, Assigned: johannh)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [anti-tracking])

Attachments

(2 files)

See design here:

https://mozilla.invisionapp.com/share/7TPU4WWJPUQ#/screens/339345388

This requires content blocking log information which will be added in bug 1522210.

Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P2 → P1
Depends on: 1525458
Whiteboard: [anti-tracking]
Target Milestone: --- → Firefox 67

This was split up in case we wanted to share the work but since I'm going to do both I'll merge it into one bug.

Summary: Create a sub-panel for cryptominers → Create a sub-panel for cryptominers and fingerprinters
Duplicate of this bug: 1522566

This is mostly a lot of boilerplate based off the trackers category/subpanels.

I would like to do some code-de-duplication, especially in browser-contentblocking,
but I figured it would be a good idea to leave that to a different bug to not obstruct
the feature from landing :)

Blocks: 1525856
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e3cc99ebb68
Add sub-panels for cryptominers and fingerprinters in the identity popup. r=nhnt11
https://hg.mozilla.org/integration/mozilla-inbound/rev/b34b924ce9c7
Tests for cryptominers and fingerprinters sub-panels. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.