Add cryptomining and fingerprinting protection options to custom content blocking preferences

RESOLVED FIXED in Firefox 67

Status

()

P1
normal
RESOLVED FIXED
23 days ago
3 hours ago

People

(Reporter: johannh, Assigned: johannh)

Tracking

(Blocks: 2 bugs)

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [anti-tracking])

Attachments

(1 attachment)

Comment 1

22 days ago

It'd be nice to have preferences to control the visibility of each one of these. We probably don't want to start landing the code with the options visible yet.

(Assignee)

Comment 2

22 days ago

(In reply to :Ehsan Akhgari from comment #1)

It'd be nice to have preferences to control the visibility of each one of these. We probably don't want to start landing the code with the options visible yet.

Yeah, I agree. To get the initial work ready for QA we can probably just add simple UI preferences that hide/show the features, but in the slightly longer run I think it'd be great to have a set of features per content blocking mode defined in prefs, which the UI draws its configuration from. We might want to do a separate bug on that if we agree.

(In reply to Johann Hofmann [:johannh] from comment #2)

(In reply to :Ehsan Akhgari from comment #1)

It'd be nice to have preferences to control the visibility of each one of these. We probably don't want to start landing the code with the options visible yet.

Yeah, I agree. To get the initial work ready for QA we can probably just add simple UI preferences that hide/show the features, but in the slightly longer run I think it'd be great to have a set of features per content blocking mode defined in prefs, which the UI draws its configuration from. We might want to do a separate bug on that if we agree.

This sounds reasonable to me.

One thing to note is that the spec requires these categories to be hidden from the primary control center UI until blocking is enabled. This is different than the way we handle the current categories, so we'll likely need to do some extra work to support that in this bug.

Comment 5

21 days ago

(In reply to Steven Englehardt [:englehardt] from comment #4)

One thing to note is that the spec requires these categories to be hidden from the primary control center UI until blocking is enabled. This is different than the way we handle the current categories, so we'll likely need to do some extra work to support that in this bug.

Right, for Trackers in the UI we show the control centre row when they are detected. I guess you're saying we should show cryptominers/fingerprinters when they're both present and blocking has been enabled for them.

Updated

17 days ago
Duplicate of this bug: 1523858
(Assignee)

Updated

11 days ago
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Comment 7

11 days ago

Created attachment 9041411 [details]
Bug 1522567 - Add cryptomining and fingerprinting protection options to custom content blocking preferences. r=ewright,flod

TODO: The icons for cryptominers and fingerprinters are still lacking "disabled" versions. Bryan will
deliver those as soon as possible.

Whiteboard: [anti-tracking]
Target Milestone: --- → Firefox 67

Comment 8

10 days ago

Note for localization. We are defining Fingerprinting as: Browser fingerprinting is a method of tracking users by the configuration and settings information that is visible to websites they browse, rather than traditional tracking methods such as IP addresses and unique cookies.

and

Cryptomining as: using scripts on websites that can use a computer’s resources to mine cryptocurrency without a user’s knowledge.

Comment 9

9 days ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a424fa81316d
Add cryptomining and fingerprinting protection options to custom content blocking preferences. r=ewright,flod

Comment 10

9 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 9 days ago
status-firefox67: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.