Closed Bug 1523020 Opened 2 years ago Closed 2 years ago

Browser Console reports some JS errors when I try to enable logging of CSS errors (and might not actually activate CSS error logging)

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox65 wontfix, firefox66 wontfix, firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: dholbert, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: [qa-67b-p2])

Attachments

(2 files)

Attached image screenshot of JS errors

STR:

  1. Ctrl+Shift+J to open Browser Console.
    (Optional: click the garbage-can to empty it of anything that's there)

  2. Click the funnel icon to the left of "filter output", and click "CSS" to turn on that logging option. (It's off by default.)

ACTUAL RESULTS:
These 5 JavaScript errors immediately appear:

/////

Error while calling actor 'parentProcessTarget's method 'ensureCSSErrorReportingEnabled' Argument 1 of InspectorUtils.getAllStyleSheets is not an object.
protocol.js:1048:5

ensureCSSErrorReportingEnabled@resource://devtools/server/actors/targets/browsing-context.js:1003:9
handler@resource://devtools/shared/protocol.js:1206:21
onPacket@resource://devtools/server/main.js:1279:15
send/<@resource://devtools/shared/transport/local-transport.js:64:11
exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
protocol.js:1051:7

stylesheets actor: fetch failed for data:text/css,, using system principal instead.
stylesheets.js:213:5

uncaught exception: Protocol error (unknownError): Argument 1 of InspectorUtils.getAllStyleSheets is not an object.

NS_BASE_STREAM_CLOSED: Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIInputStream.available]
DevToolsUtils.js:607

/////

EXPECTED RESULTS: No such errors.

Priority: -- → P2
Duplicate of this bug: 1524600

Copying some flags from my dupe. Pretty sure this is a regression, might be interesting to work out from what...

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

(In reply to Alice0775 White from comment #3)

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dc5ea0cbf005b65654b6ed8f44f447011295f0e3&tochange=544320932f97d62f477bedd6296690fb164b846f

Suspect : 544320932f97 Kris Maglione — Bug 1463291: Move docShell getter from Document to Window. r=bz

This was a reasonable guess, but it actually turns out to be https://hg.mozilla.org/integration/mozilla-inbound/rev/60c1c783f5e1 which removed a bunch of nsIWebNavigation QIs.

Blocks: 1463016
No longer blocks: 1463291

(I put up a patch at https://phabricator.services.mozilla.com/D18675 but for some reason phab is not playing ball)

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/68a7366af27b
QI docshells to nsIWebNavigation when trying to access their .document property, r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Is this something which should be considered for backport or can it ride the trains?

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #10)

Is this something which should be considered for backport or can it ride the trains?

Passing to Nicolas, I'm not sure how much this fixes and if it's worth uplifting.

Nicolas: also, on phab you said you'd file a follow-up - I don't see one on this bug or in your bmo activity, but perhaps I'm missing it?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(nchevobbe)

I don't think it's worth uplifting.

Nicolas: also, on phab you said you'd file a follow-up - I don't see one on this bug or in your bmo activity, but perhaps I'm missing it?

Thanks for the reminder, I filed Bug 1529865 for this.

Flags: needinfo?(nchevobbe)
Whiteboard: [qa-67b-p2]
You need to log in before you can comment on or make changes to this bug.