Closed Bug 1523063 Opened 1 year ago Closed 1 year ago

Long "Vice News" articles jump straight to the end when you click "read more", when Scroll Anchoring is enabled

Categories

(Core :: Layout: Scrolling and Overflow, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified

People

(Reporter: dholbert, Assigned: rhunt)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: regression)

STR:

  1. View this article in either Fennec or in a GeckoView browser (same results):
    https://news.vice.com/en_us/article/xwpmmw/the-1971-student-massacre-that-mexico-would-rather-forget

  2. Scroll down until the "Read More" button is on the top half of the screen (but article text is still visible)

  3. Click the "Read More" button.

EXPECTED RESULTS:
Article content should remain anchored in position as new content loads.

ACTUAL RESULTS:
Article content gets scrolled way to the end, as the new content loads. I'm jumped from looking at the ~10% through point [with the rest behind the "read more" button] to suddenly looking at the very end of the article.

If I enable layout.css.scroll-anchoring.highlight, I can see that the after-the-article promotional content (after the "Read More" button) gets chosen as the anchor for some reason. In other words, Fennec/GeckoView anchor on some "after-the-article" content, and the new article content was treated as if it were irrelevant stuff loading out of view above the viewport.

In both Fennec and GeckoView (Android "Reference Browser"), I get ACTUAL RESULTS with scroll anchoring preffed on, vs. EXPECTED RESULTS with scroll anchoring preffed off.

In Firefox Nightly on Desktop in Responsive Design Mode, I get EXPECTED RESULTS -- and scroll anchoring highlighting does what I'd expect (highlighting the still-visible text from the actual article).

Summary: Long "Vice News" articles jump straight to the end when you click "read more" → Long "Vice News" articles jump straight to the end when you click "read more", when Scroll Anchoring is enabled

(Also, Chrome gives "expected results" on both Android & Desktop.)

My phone hardware is a Pixel 3 running Android P, in case it matters.

Flags: needinfo?(rhunt)

This looks like a regression from bug 1518640. It should be fixed by bug 1522264.

Flags: needinfo?(rhunt)

Can you still reproduce this now that bug 1518640 has landed?

Flags: needinfo?(dholbert)

(In reply to Ryan Hunt [:rhunt] from comment #3)

Can you still reproduce this now that bug 1518640 has landed?

That bug landed before I filed this bug... maybe you meant to link a different one?

Anyway: I cannot reproduce in Firefox Nightly (Fennec) on android anymore. (I tried my main profile, and also used "Tools|New Guest Session" to be sure I'm testing default configuration).

However, I can still reproduce on the "Reference Browser". I don't know what its update schedule is like, though. I installed an update for it this morning, but its "about" page has 2019-01-28 as a datestamp in the version number, and perhaps that's too early to get the fix that you're suspecting will have fixed this?

Flags: needinfo?(dholbert) → needinfo?(rhunt)

I'm guessing you meant to say "...now that bug 1522264 has landed" [note that that bug's not closed, but it did have a patch land and stick on 1/29].

If so: I think that makes sense & I think we can consider this fixed-by-that-bug, yeah. That explains the Firefox Nightly vs. Jan-28th-reference-browser distinction in comment 4, too.

(In reply to Daniel Holbert [:dholbert] from comment #5)

I'm guessing you meant to say "...now that bug 1522264 has landed" [note
that that bug's not closed, but it did have a patch land and stick on 1/29].

If so: I think that makes sense & I think we can consider this
fixed-by-that-bug, yeah. That explains the Firefox Nightly vs.
Jan-28th-reference-browser distinction in comment 4, too.

Ah yes, that's the bug I meant. The regression was added by bug 1518640.

Flags: needinfo?(rhunt)

Resolved by the first patch that landed in bug 1522264.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Assignee: nobody → rhunt
Depends on: 1522264
Target Milestone: --- → mozilla67

Ryan, is this something you might also bring to beta? If it did fix the scroll anchoring issue here, that is, even if it didn't completely fix the test issue in bug 1522264.

Flags: needinfo?(rhunt)

Yes the patch for this should definitely go to beta, as even though it has an intermittent test failure, it still fixes this more serious issue.

Flags: needinfo?(rhunt)

OK great, can you request uplift? Probably will make it into beta 9.

Flags: needinfo?(rhunt)

Oh, never mind, I see you already did.

Flags: needinfo?(rhunt)
Whiteboard: [qa-triaged]

Ovidiu would you or your team check to see that this is fixed in beta? Thanks!

Flags: needinfo?(ovidiu.boca)

Verified as fixed on Beta 66.0b11, and Nightly 67.0a1 (2019-02-27), on Google Pixel (Android 9.0), and OnePlus 5T (Android 9.0).
Thank you!

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(ovidiu.boca)
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.