I got "command failed" when bootstrapping xpcomsample

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: hwaara, Assigned: mcafee)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

17 years ago
Here's the log from what I did, and what happened. Note that "minimoz" is the
folder above my real source tree.

--

C:\src\mozilla\minimoz>perl bootstrap.pl --module=xpcomsample
root_modules = xpcomsample


Pulling core build files...
cmd = cvs co mozilla/client.mk mozilla/config mozilla/configure mozilla/configur
e.in mozilla/aclocal.m4 mozilla/Makefile.in mozilla/build mozilla/include mozill
a/tools/module-deps
Warning, cmd exited with status 1.


Pulling nspr...
cmd = cvs co -rNSPRPUB_PRE_4_2_CLIENT_BRANCH  mozilla/nsprpub


Pulling modules...
cp mozilla/tools/module-deps/all.dot  mozilla/tools/module-deps/meta.dot

Dependency tree:
  xpcomsample
    xpcom
    xpcomsample
    string


cmd = mozilla/tools/module-deps/module-graph.pl --file mozilla/tools/module-deps
/meta.dot --start-module xpcomsample --list-only --force-order mozilla/tools/mod
ule-deps/force_order.txt
modules = 4

Generating directories list...
cmd = echo string xpcom xpcomsample xpcomsample   | mozilla/config/module2dir.pl
 --list-only

dirs_string_no_mozilla = string xpcom

Checking out directories...
cmd = cvs co mozilla/string mozilla/xpcom

Generating allmakefiles.sh ...
cp mozilla/tools/module-deps/allmakefiles.stub mozilla/allmakefiles.sh

Configuring ...
cmd = ./configure --enable-standalone-modules=xpcomsample --disable-ldap --disab
le-tests --disable-installer
command failed: No such file or directory at bootstrap.pl line 109.

C:\src\mozilla\minimoz>

--
(Assignee)

Comment 1

17 years ago
garrett was getting this error too, I think the wrapper to system() isn't
working for some cases.
(Reporter)

Comment 2

17 years ago
Marking critical, because I can't use the tool (maybe it should be even blocker).
Severity: normal → critical
Oops.  If we expect this to run on win32 in a non-cygwin shell, we should be
explicitly calling sh to run the configure script.

-  my $configure_cmd = "./configure --enable-standalone-modules=$root_modules
--disable-ldap --disable-tests --disable-installer";
+  my $configure_cmd = "sh ./configure --enable-standalone-modules=$root_modules
--disable-ldap --disable-tests --disable-installer";
(Assignee)

Comment 4

17 years ago
r=mcafee for sh change, this looks fine to me.
(Reporter)

Comment 5

17 years ago
I ran with the change, but it wouldn't build. Not sure why this is. 

Here is the relevant output:

--
Building ...
basedir = /cygdrive/c/src/mozilla/minimoz
make -C mozilla/nsprpub
make: Entering directory `/cygdrive/c/src/mozilla/minimoz/mozilla/nsprpub'
make: *** No targets specified and no makefile found.  Stop.
make: Leaving directory `/cygdrive/c/src/mozilla/minimoz/mozilla/nsprpub'
make -C mozilla/config
make: Entering directory `/cygdrive/c/src/mozilla/minimoz/mozilla/config'
make: *** No targets specified and no makefile found.  Stop.
make: Leaving directory `/cygdrive/c/src/mozilla/minimoz/mozilla/config'
make -C mozilla/xpcom/typelib
make: Entering directory `/cygdrive/c/src/mozilla/minimoz/mozilla/xpcom/typelib'

make: *** No targets specified and no makefile found.  Stop.
make: Leaving directory `/cygdrive/c/src/mozilla/minimoz/mozilla/xpcom/typelib'
make: *** No rule to make target `export-idl'.  Stop.
make: *** No rule to make target `export'.  Stop.
make: *** No rule to make target `libs'.  Stop.
--
The configure run failed.  Can you attach the complete output?
(Reporter)

Comment 7

17 years ago
You mean this?

--
Configuring ...
cmd = sh ./configure --enable-standalone-modules=xpcomsample --disable-ldap --di
sable-tests --disable-installer
Warning, cmd exited with status 1.
--
Right.  We should be checking the results of $rv since it's obvious that
configure failed there.  Hwaara, do you have a config.log?  Could you also try
removing the '2>&1' from line 109 so  that we can see the actual build output?  

Over to mcafee.
Assignee: seawood → mcafee
(Reporter)

Comment 9

17 years ago
cls said over IRC that I should print out the $rv of the line where we run the
command. I tried, but got the same output as in comment 7.  mcafee or cls: could
you just run this command:  perl bootstrap.pl --module=xpcomsample and try to
reproduce the bug? I don't come very far with my attempts.
(Assignee)

Comment 10

17 years ago
Created attachment 88038 [details] [diff] [review]
xpcomsample wasn't in the module2dir map, adding it with this patch
(Reporter)

Comment 11

17 years ago
Comment on attachment 88038 [details] [diff] [review]
xpcomsample wasn't in the module2dir map, adding it with this patch

r=hwaara

please checkin the other fix as well.
Attachment #88038 - Flags: review+
(Assignee)

Comment 12

17 years ago
Created attachment 88046 [details] [diff] [review]
patch to specify sh on configure line, for bootstrap.pl

here is the patch hwaara is talking about.
(Reporter)

Comment 13

17 years ago
Comment on attachment 88046 [details] [diff] [review]
patch to specify sh on configure line, for bootstrap.pl

r=hwaara
Attachment #88046 - Flags: review+

Comment 14

17 years ago
Comment on attachment 88038 [details] [diff] [review]
xpcomsample wasn't in the module2dir map, adding it with this patch

sr=alecf
Attachment #88038 - Flags: superreview+

Comment 15

17 years ago
Comment on attachment 88046 [details] [diff] [review]
patch to specify sh on configure line, for bootstrap.pl

sr=alecf
Attachment #88046 - Flags: superreview+
(Assignee)

Comment 16

17 years ago
Comment on attachment 88046 [details] [diff] [review]
patch to specify sh on configure line, for bootstrap.pl

sh fix checked in
Attachment #88046 - Attachment is obsolete: true
(Assignee)

Comment 17

17 years ago
Comment on attachment 88038 [details] [diff] [review]
xpcomsample wasn't in the module2dir map, adding it with this patch

xpcomsample module2dir.pl entry checked in.
Attachment #88038 - Attachment is obsolete: true
(Assignee)

Comment 18

17 years ago
I can build xpcomsample on linux now, I get dist/{bin,idl,include,lib,sdk} ok.
(Reporter)

Comment 19

17 years ago
I can't find the "sh fix" checkin in bonsai? Did you just forget it, or am I
missing something?
(Reporter)

Comment 20

17 years ago
Sorry, I didn't know bootstrap.pl wasn't in the SeaMonkey CVS module.
(Assignee)

Comment 21

17 years ago
marking fixed, please reopen if it's not working for you.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.